CVE-2021-21305

highpriority · track · 39EPSS 0.127 · 96 %ileEUUS
grimoire priorityP1 · Urgent
Exploitable?
—
no known exploitation
Likely / severe?
12.7% (96th) EPSS
CVSS 7.5 · high
Is it mine?
6 products
Check your exposure
Who says so?
4 sources
cnnvd · enisa_euvd · nvd · osv

EPSS · scored 2026-10-27

CarrierWave is an open-source RubyGem which provides a simple and flexible way to upload files from Ruby applications. In CarrierWave before versions 1.3.2 and 2.1.1, there is a code injection vulnerability. The "#manipulate!" method inappropriately evals the content of mutation option(:read/:write), allowing attackers to craft a string that can be executed as a Ruby code. If an application developer supplies untrusted inputs to the option, it will lead to remote code execution(RCE). This is fixed in versions 1.3.2 and 2.1.1.

01

cvss

Technical severity, 0–10. One row per scoring source.

8.8
010

base score 0–10 · higher = more severe · hover a vector to decode

v2.07.5highAV:N/AC:L/Au:N/C:P/I:P/A:Pprimary · NVD / NIST USexploitability 10 · impact 6.4
v3.18.8highCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:Hprimary · NVD / NIST USexploitability 2.8 · impact 5.9
v3.17.4highCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:Lsecondary · ENISA EU
v3.17.4highCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:Lsecondary · security-advisories@github.comexploitability 3.1 · impact 3.7
v3.17.4highCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:Lsecondary · OSV
v3.18.1highCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:Usecondary · CVSS-BT (t0sche)
02

weaknesses

The CWE weakness classes this flaw belongs to.

03

affected products (6)

Products and version ranges known to be affected.

04

advisories (1)

Vendor and ecosystem advisories describing this.

  • GHSA-cf3w-g86h-35x4Code Injection vulnerability in CarrierWave::RMagick2021-02-08ghsa · osvUS

    ### Impact [CarrierWave::RMagick](https://github.com/carrierwaveuploader/carrierwave/blob/master/lib/carrierwave/processing/rmagick.rb) has a Code Injection vulnerability. Its `#manipulate!` method inappropriately evals the content of mutation option(`:read`/`:write`), allowing attackers to craft a string that can be executed as a Ruby code. If an application developer supplies untrusted inputs to the option, it will lead to remote code execution(RCE). (But supplying untrusted input to the option itself is dangerous even in absence of this vulnerability, since is prone to DoS vulnerability - attackers can try to consume massive amounts of memory by resizing to a very large dimension) ### Proof of Concept ```ruby class MyUploader < CarrierWave::Uploader::Base include CarrierWave::RMagick end MyUploader.new.manipulate!({ read: { density: "1 }; p 'Hacked'; {" }}) # => shows "Hacked" ``` ### Patches Upgrade to [2.1.1](https://rubygems.org/gems/carrierwave/versions/2.1.1) or [1.3.2](https://rubygems.org/gems/carrierwave/versions/1.3.2). ### Workarounds Stop supplying untrusted input to `#manipulate!`'s mutation option. ### References [Code Injection Software Attack](https://owasp.org/www-community/attacks/Code_Injection) ### For more information If you have any questions or comments about this advisory: * Open an issue in [CarrierWave repo](https://github.com/carrierwaveuploader/carrierwave) * Email me at [mit.shibuya@gmail.com](mailto:mit.shibuya@gmail.com)

05

also known as (3)

Other names and identifiers for this entity.

06

sources

Which sources assert this record, and when.

published 2021-02-08modified 2026-06-17
08

references (16)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan