CVE-2021-21028
mediumpriority · track · 36EPSS 0.041 · 91 %ileEURUUSEPSS · scored 2026-10-28
Acrobat Reader DC versions versions 2020.013.20074 (and earlier), 2020.001.30018 (and earlier) and 2017.011.30188 (and earlier) are affected by a Use After Free vulnerability. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.1–8.8
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (17)
Products and version ranges known to be affected.
advisories (3)
Vendor and ecosystem advisories describing this.
- GHSA-7r83-w6r8-fh6wReflected Cross-site Scripting (XSS) in ACS Commons2021-05-13ghsa · osvUS
ACS Commons version 4.9.2 (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in version-compare and page-compare due to invalid JCR characters that are not handled correctly. An attacker could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. Exploitation of this issue requires user interaction in order to be successful.
- GHSA-f92j-qf46-p6vmReflected Cross-site Scripting in ACS Commons2021-02-02ghsa · osvUS
### Impact ACS Commons version 4.9.2 (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in version-compare and page-compare due to invalid JCR characters that are not handled correctly. An attacker could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. Exploitation of this issue requires user interaction in order to be successful. ### Patches This issue has been resolved in v4.10.0 ### Workarounds No workaround exist. ### References N/A ### For more information If you have any questions or comments about this advisory open an issue in acs-aem-commons. ### Credit This issue was discovered and reported by Christopher Whipp (Christopher.Whipp@servicesaustralia.gov.au).
- CVE-2021-210432021-02-02vendor · osvUS
ACS Commons version 4.9.2 (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in version-compare and page-compare due to invalid JCR characters that are not handled correctly. An attacker could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. Exploitation of this issue requires user interaction in order to be successful.
also known as (6)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (7)
External citations — patches, advisories, analysis.
- https://helpx.adobe.com/security/products/acrobat/apsb21-09.htmlcnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2021-21028cnnvd
- https://vigilance.fr/vulnerability/Adobe-Acrobat-Reader-multiple-vulnerabilities-34526cnnvd
- https://www.auscert.org.au/bulletins/ESB-2021.0443cnnvd
- https://www.zerodayinitiative.com/advisories/ZDI-21-169/cnnvd
- https://helpx.adobe.com/security/products/acrobat/apsb21-09.htmlenisa_euvd
- https://helpx.adobe.com/security/products/acrobat/apsb21-09.htmlVendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan