CVE-2020-26217
highpriority · attend · 74EPSS 0.827 · 100 %ileexploit · PoCDEEURUUSEPSS · scored 2026-10-27
XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (6)
Public proof-of-concept and weaponised exploit code.
- Al1ex/CVE-2020-26217CVE-2020-26217 && XStream RCEPoC · poc_in_github
- Kairo-one/CVE-2020-26217-XStreamCVE-2020-26217 XStream反序列化的pocPoC · poc_in_github
- cuijiung/xstream-CVE-2020-26217cuijiung/xstream-CVE-2020-26217PoC · poc_in_github
- epicosy/XStream-1xstream with CVE-2020-26217PoC · poc_in_github
- novysodope/CVE-2020-26217-XStream-RCE-POCCVE-2020-26217 XStream RCE POCPoC · poc_in_github
affected products (46)
Products and version ranges known to be affected.
- oracle banking corporate lending process management= 14.2nvdUScpe:2.3:a:oracle:banking_corporate_lending_process_management:*:*:*:*:*:*:*:*
- oracle banking corporate lending process management= 14.3nvdUScpe:2.3:a:oracle:banking_corporate_lending_process_management:*:*:*:*:*:*:*:*
- oracle banking corporate lending process management= 14.5nvdUScpe:2.3:a:oracle:banking_corporate_lending_process_management:*:*:*:*:*:*:*:*
- oracle banking credit facilities process management= 14.2nvdUScpe:2.3:a:oracle:banking_credit_facilities_process_management:*:*:*:*:*:*:*:*
- oracle banking credit facilities process management= 14.3nvdUScpe:2.3:a:oracle:banking_credit_facilities_process_management:*:*:*:*:*:*:*:*
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2024-0094Atlassian Bamboo: Mehrere SchwachstellenDeutsch2024-01-15csaf · cert_bundDE
Ein entfernter Angreifer kann mehrere Schwachstellen in Atlassian Bamboo ausnutzen, um einen Denial-of-Service-Zustand zu erzeugen, beliebigen Code auszuführen, vertrauliche Informationen offenzulegen oder einen Request Smuggling-Angriff durchzuführen.
- WID-SEC-W-2026-0180Dell Data Protection Advisor: Mehrere SchwachstellenDeutsch2026-01-20csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Dell Data Protection Advisor ausnutzen, um beliebigen Code auszuführen, einen Denial-of-Service-Zustand zu erzeugen, Sicherheitsmaßnahmen zu umgehen und nicht näher spezifizierte Angriffe zu starten.
- GHSA-mw36-7c6c-q4q2XStream can be used for Remote Code Execution2020-11-16ghsa · osvUS
### Impact The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. ### Patches If you rely on XStream's default blacklist of the [Security Framework](https://x-stream.github.io/security.html#framework), you will have to use at least version 1.4.14. ### Workarounds No user is affected, who followed the recommendation to setup XStream's Security Framework with a whitelist! Anyone relying on XStream's default blacklist can immediately switch to a whilelist for the allowed types to avoid the vulnerability. Users of XStream 1.4.13 or below who still want to use XStream default blacklist can use a workaround depending on their version in use. Users of XStream 1.4.13 can simply add two lines to XStream's setup code: ```Java xstream.denyTypes(new String[]{ "javax.imageio.ImageIO$ContainsFilter" }); xstream.denyTypes(new Class[]{ java.lang.ProcessBuilder.class }); ``` Users of XStream 1.4.12 to 1.4.7 who want to use XStream with a black list will have to setup such a list from scratch and deny at least the following types: _javax.imageio.ImageIO$ContainsFilter_, _java.beans.EventHandler_, _java.lang.ProcessBuilder_, _java.lang.Void_ and _void_. ```Java xstream.denyTypes(new String[]{ "javax.imageio.ImageIO$ContainsFilter" }); xstream.denyTypes(new Class[]{ java.lang.ProcessBuilder.class, java.beans.EventHandler.class, java.lang.ProcessBuilder.class, java.lang.Void.class, void.class }); ``` Users of XStream 1.4.6 or below can register an own converter to prevent the unmarshalling of the currently know critical types of the Java runtime. It is in fact an updated version of the workaround for CVE-2013-7285: ```Java xstream.registerConverter(new Converter() { public boolean canConvert(Class type) { return type != null && (type == java.beans.EventHandler.class || type == java.lang.ProcessBuilder.class || type == java.lang.Void.class || void.class || type.getName().equals("javax.imageio.ImageIO$ContainsFilter") || Proxy.isProxy(type)); } public Object unmarshal(HierarchicalStreamReader reader, UnmarshallingContext context) { throw new ConversionException("Unsupported type due to security reasons."); } public void marshal(Object source, HierarchicalStreamWriter writer, MarshallingContext context) { throw new ConversionException("Unsupported type due to security reasons."); } }, XStream.PRIORITY_LOW); ``` ### Credits Chen L found and reported the issue to XStream and provided the required information to reproduce it. He was supported by Zhihong Tian and Hui Lu, both from Guangzhou University. ### References See full information about the nature of the vulnerability and the steps to reproduce it in XStream's documentation for [CVE-2020-26217](https://x-stream.github.io/CVE-2020-26217.html). ### For more information If you have any questions or comments about this advisory: * Open an issue in [XStream](https://github.com/x-stream/xstream/issues) * Contact us at [XStream Google Group](https://groups.google.com/group/xstream-user)
- BIT-activemq-2020-26217Remote Code Execution in XStream2025-12-03vendor · osvUS
XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.
also known as (6)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (77)
External citations — patches, advisories, analysis.
- https://github.com/x-stream/xstream/commit/0fec095d534126931c99fd38e9c6d41f5c685c1acnnvd
- https://github.com/x-stream/xstream/security/advisories/GHSA-mw36-7c6c-q4q2cnnvd
- https://lists.apache.org/thread.html/r2de526726e7f4db4a7cb91b7355070779f51a84fd985c6529c2f4e9e@%3Cissues.activemq.apache.org%3Ecnnvd
- https://lists.apache.org/thread.html/r7c9fc255edc0b9cd9567093d131f6d33fde4c662aaf912460ef630e9@%3Ccommits.camel.apache.org%3Ecnnvd
- https://lists.apache.org/thread.html/r826a006fda71cc96fc87b6eca4b5d195f19a292ad36cea501682c38c@%3Cissues.activemq.apache.org%3Ecnnvd
- https://lists.apache.org/thread.html/redde3609b89b2a4ff18b536a06ef9a77deb93d47fda8ed28086fa8c3@%3Cissues.activemq.apache.org%3Ecnnvd
- https://lists.debian.org/debian-lts-announce/2020/12/msg00001.htmlcnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2020-26217cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan