CVE-2020-2243
lowpriority · track · 22EPSS 0.008 · 55 %ileEUUSEPSS · scored 2026-10-27
Jenkins Cadence vManager Plugin 3.0.4 and earlier does not escape build descriptions in tooltips, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Run/Update permission.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–high · 3.5–8
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (3)
Products and version ranges known to be affected.
- Maven org.jenkins-ci.plugins:vmanager-plugin< 3.0.5osvUSpkg:maven/org.jenkins-ci.plugins/vmanager-plugin
advisories (1)
Vendor and ecosystem advisories describing this.
- GHSA-v46q-xjp5-7p6rStored XSS vulnerability in Jenkins Cadence vManager Plugin2022-05-24ghsa · osvUS
Jenkins Cadence vManager Plugin 3.0.4 and earlier does not escape build descriptions in tooltips, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Run/Update permission. Cadence vManager Plugin 3.0.5 removes affected tooltips.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (10)
External citations — patches, advisories, analysis.
- http://www.nsfocus.net/vulndb/49657cnnvd
- http://www.openwall.com/lists/oss-security/2020/09/01/3cnnvd
- https://jenkins.io/security/advisory/2020-09-01/#SECURITY-1936cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2020-2243cnnvd
- https://vigilance.fr/vulnerabilite/Jenkins-Plugins-multiples-vulnerabilites-33205Patchcnnvd
- https://vigilance.fr/vulnerability/Jenkins-Plugins-multiple-vulnerabilities-33205cnnvd
- http://www.openwall.com/lists/oss-security/2020/09/01/3enisa_euvd
- https://jenkins.io/security/advisory/2020-09-01/#SECURITY-1936enisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan