CVE-2019-15795

lowpriority · track · 19OT risk · elevatedEPSS 0.005 · 39 %ileEURUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
0.45% (39th) EPSS
CVSS 2.6 · low
Is it mine?
50 products
Check your exposure
Who says so?
5 sources
cnnvd · enisa_euvd · fstec_bdu · nvd

EPSS · scored 2026-10-28

python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.

01

cvss

Technical severity, 0–10. One row per scoring source.

4.7
010

base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 2.6–4.7

v2.02.6lowAV:N/AC:H/Au:N/C:N/I:P/A:Nprimary · NVD / NIST USexploitability 4.9 · impact 2.9
v3.14.7mediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:Nprimary · NVD / NIST USexploitability 1.6 · impact 2.7
v3.13.4lowAV:N/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:Nsecondary · FSTEC (BDU) RU
v3.14.7mediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · ENISA EU
v3.14.7mediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · security@ubuntu.comexploitability 1.6 · impact 2.7
v3.14.7mediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · OSV
v3.14.3mediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N/E:Usecondary · CVSS-BT (t0sche)
02

weaknesses

The CWE weakness classes this flaw belongs to.

03

affected products (50)

Products and version ranges known to be affected.

04

advisories (1)

Vendor and ecosystem advisories describing this.

  • GHSA-rp8m-h266-53jhpython-apt Flawed Package Integrity Check2022-05-24ghsa · osvUS

    python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.

05

also known as (4)

Other names and identifiers for this entity.

06

sources

Which sources assert this record, and when.

published 2020-03-26modified 2026-06-17
08

references (12)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan