CVE-2019-1003042
lowpriority · track · 22EPSS 0.014 · 72 %ileEURUUSEPSS · scored 2026-10-27
A cross site scripting vulnerability in Jenkins Lockable Resources Plugin 2.4 and earlier allows attackers able to control resource names to inject arbitrary JavaScript in web pages rendered by the plugin.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- Fixedjenkins-2-plugins-0:3.11.1553788831-1.el7.noarch as a component of Red Hat OpenShift Container Platform 3.11redhat_csaf
See the following documentation, which will be updated shortly for this release, for important instructions on how to upgrade your cluster and fully apply this asynchronous errata update: https://docs.openshift.com/container-platform/3.11/release_notes/ocp_3_11_release_notes.html
https://access.redhat.com/errata/RHSA-2019:1423 - Fixedjenkins-2-plugins-0:3.11.1553788831-1.el7.src as a component of Red Hat OpenShift Container Platform 3.11redhat_csaf
See the following documentation, which will be updated shortly for this release, for important instructions on how to upgrade your cluster and fully apply this asynchronous errata update: https://docs.openshift.com/container-platform/3.11/release_notes/ocp_3_11_release_notes.html
https://access.redhat.com/errata/RHSA-2019:1423
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 3.5–6.1
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (7)
Products and version ranges known to be affected.
advisories (2)
Vendor and ecosystem advisories describing this.
- RHSA-2019:1423Red Hat Security Advisory: Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins security update2019-06-10csaf · redhat_csafUS
An update for jenkins-2-plugins is now available for Red Hat OpenShift Container Platform 3.11. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.
- GHSA-wqjj-c9cx-q7cfJenkins Lockable Resources Plugin XSS vulnerability2022-05-13ghsa · osvUS
A cross site scripting vulnerability in Jenkins Lockable Resources Plugin 2.4 and earlier allows attackers able to control resource names to inject arbitrary JavaScript in web pages rendered by the plugin.
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (16)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2019/03/28/2cnnvd
- http://www.securityfocus.com/bid/107628cnnvd
- https://access.redhat.com/errata/RHSA-2019:1423cnnvd
- https://jenkins.io/security/advisory/2019-03-25/#SECURITY-1089Patchcnnvd
- https://jenkins.io/security/advisory/2019-03-25/#SECURITY-1361cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2019-1003042cnnvd
- https://www.auscert.org.au/bulletins/ESB-2019.2067/cnnvd
- https://www.securityfocus.com/bid/107628cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan