CVE-2019-1000010
mediumpriority · track · 24EPSS 0.009 · 58 %ileEUUSEPSS · scored 2026-10-28
phpIPAM version 1.3.2 and earlier contains a Cross Site Scripting (XSS) vulnerability in subnet-scan-telnet.php that can result in executing code in victims browser. This attack appears to be exploitable via victim visits link crafted by an attacker. This vulnerability appears to have been fixed in 1.4.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (2)
Products and version ranges known to be affected.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (8)
External citations — patches, advisories, analysis.
- https://github.com/phpipam/phpipam/commit/fd37bd8fb2b9c306079db505e0e3fe79a096c31cPatchcnnvd
- https://github.com/phpipam/phpipam/commit/fd37bd8fb2b9c306079db505e0e3fe79a096c31cPatchThirdcnnvd
- https://github.com/phpipam/phpipam/issues/2327ExploitIssuecnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2019-1000010cnnvd
- https://github.com/phpipam/phpipam/commit/fd37bd8fb2b9c306079db505e0e3fe79a096c31cenisa_euvd
- https://github.com/phpipam/phpipam/issues/2327enisa_euvd
- https://github.com/phpipam/phpipam/commit/fd37bd8fb2b9c306079db505e0e3fe79a096c31cPatchThird Party Advisorynvd
- https://github.com/phpipam/phpipam/issues/2327ExploitIssue TrackingThird Party Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan