CVE-2018-1000808
mediumpriority · track · 25EPSS 0.019 · 80 %ileDEEUUSEPSS · scored 2026-10-27
Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (12)
Products and version ranges known to be affected.
- redhat enterprise linux workstation= 7.0nvdUScpe:2.3:o:redhat:enterprise_linux_workstation:*:*:*:*:*:*:*:*
advisories (3)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2024-1099python-crypto: Mehrere SchwachstellenDeutsch2018-12-10csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in python-crypto ausnutzen, um beliebigen Programmcode auszuführen und um einen Denial of Service Zustand herbeizuführen.
- GHSA-2rcm-phc9-3945Pyopenssl Incorrect Memory Management2018-10-10ghsa · osvUS
It was discovered that pyOpenSSL incorrectly handled memory when performing operations on a PKCS #12 store. A remote attacker could possibly use this issue to cause pyOpenSSL to consume resources, resulting in a denial of service. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection that would cause the calling application to reload certificates from a PKCS #12 store. This vulnerability appears to have been fixed in 17.5.0.
- PYSEC-2018-242018-10-08vendor · osvUS
Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.
also known as (6)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (12)
External citations — patches, advisories, analysis.
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00014.htmlcnnvd
- https://access.redhat.com/errata/RHSA-2019:0085cnnvd
- https://github.com/pyca/pyopenssl/pull/723cnnvd
- https://usn.ubuntu.com/3813-1/cnnvd
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00014.htmlenisa_euvd
- https://access.redhat.com/errata/RHSA-2019:0085enisa_euvd
- https://github.com/pyca/pyopenssl/pull/723enisa_euvd
- https://usn.ubuntu.com/3813-1/enisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan