CVE-2018-1000807
mediumpriority · track · 33EPSS 0.041 · 91 %ileDEEUUSEPSS · scored 2026-10-27
Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.8–8.1
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (11)
Products and version ranges known to be affected.
- redhat enterprise linux workstation= 7.0nvdUScpe:2.3:o:redhat:enterprise_linux_workstation:*:*:*:*:*:*:*:*
advisories (3)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2024-1099python-crypto: Mehrere SchwachstellenDeutsch2018-12-10csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in python-crypto ausnutzen, um beliebigen Programmcode auszuführen und um einen Denial of Service Zustand herbeizuführen.
- GHSA-p28m-34f6-967qPyOpenSSL Use-After-Free vulnerability2018-10-10ghsa · osvUS
It was discovered that pyOpenSSL incorrectly handled memory when handling X509 objects. A remote attacker could use this issue to cause pyOpenSSL to crash, resulting in a denial of service, or possibly execute arbitrary code. This attack appears to be exploitable via Depends on the calling application and if it retains a reference to the memory. This vulnerability appears to have been fixed in 17.5.0.
- PYSEC-2018-232018-10-08vendor · osvUS
Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.
also known as (6)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (14)
External citations — patches, advisories, analysis.
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00014.htmlcnnvd
- https://access.redhat.com/errata/RHSA-2019:0085cnnvd
- https://github.com/pyca/pyopenssl/pull/723cnnvd
- https://usn.ubuntu.com/3813-1/cnnvd
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00014.htmlenisa_euvd
- https://access.redhat.com/errata/RHSA-2019:0085enisa_euvd
- https://github.com/pyca/pyopenssl/commit/e73818600065821d588af475b024f4eb518c3509enisa_euvd
- https://github.com/pyca/pyopenssl/pull/723enisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan