CVE-2018-1000168
mediumpriority · track · 34EPSS 0.106 · 96 %ileEUUSEPSS · scored 2026-10-28
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 5–7.5
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (7)
Products and version ranges known to be affected.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (26)
External citations — patches, advisories, analysis.
- http://www.securityfocus.com/bid/103952cnnvd
- https://access.redhat.com/errata/RHSA-2019:0366cnnvd
- https://access.redhat.com/errata/RHSA-2019:0367cnnvd
- https://lists.debian.org/debian-lts-announce/2021/10/msg00011.htmlcnnvd
- https://ngcnnvd
- https://nghttp2.org/blog/2018/04/12/nghttp2-v1-31-1/Patchcnnvd
- https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/cnnvd
- https://packetstormsecurity.com/files/151742/Red-Hat-Security-Advisory-2019-0367-01.htmlcnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan