CVE-2017-7550
mediumpriority · track · 40EPSS 0.036 · 89 %ileDEEUUSEPSS · scored 2026-10-27
A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- Fixedansible-0:2.4.0.0-5.el7.noarch as a component of Red Hat Enterprise Linux 7 Extrasredhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2017:2966 - Fixedansible-0:2.4.0.0-5.el7.src as a component of Red Hat Enterprise Linux 7 Extrasredhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2017:2966 - Fixedansible-doc-0:2.4.0.0-5.el7.noarch as a component of Red Hat Enterprise Linux 7 Extrasredhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2017:2966
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–critical · 5–9.8
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (16)
Products and version ranges known to be affected.
- Red Hat Enterprise Linux Server 7 x86_64all versionscert_bundDEcpe:/o:redhat:enterprise_linux:7_x86_64
advisories (4)
Vendor and ecosystem advisories describing this.
- RHSA-2017:2966Red Hat Security Advisory: ansible security, bug fix, and enhancement update2017-10-19csaf · redhat_csafUS
An update for ansible is now available for Red Hat Enterprise Linux 7 Extras. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.
- WID-SEC-W-2024-1038Red Hat Enterprise Linux Server: Schwachstelle ermöglicht Offenlegung von InformationenDeutsch2017-10-19csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in Red Hat Enterprise Linux Server ausnutzen, um Informationen offenzulegen.
- GHSA-588w-w6mv-3cw5Ansible Insertion of Sensitive Information into Log File vulnerability2022-05-13ghsa · osvUS
A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.
- PYSEC-2017-42017-11-21vendor · osvUS
A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.
also known as (6)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (10)
External citations — patches, advisories, analysis.
- https://access.redhat.com/errata/RHSA-2017:2966cnnvd
- https://access.redhat.com/security/cve/CVE-2017-7550cnnvd
- https://bugzilla.redhat.com/show_bug.cgi?id=1473645cnnvd
- https://github.com/ansible/ansible/issues/30874cnnvd
- https://access.redhat.com/errata/RHSA-2017:2966enisa_euvd
- https://bugzilla.redhat.com/show_bug.cgi?id=1473645enisa_euvd
- https://github.com/ansible/ansible/issues/30874enisa_euvd
- https://access.redhat.com/errata/RHSA-2017:2966Issue TrackingThird Party Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan