CVE-2017-18342
highpriority · track · 41EPSS 0.057 · 93 %ileDEEURUUSEPSS · scored 2026-10-27
In PyYAML before 5.1, the yaml.load() API could execute arbitrary code if used with untrusted data. The load() function has been deprecated in version 5.1 and the 'UnsafeLoader' has been introduced for backward compatibility with the function.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · high–critical · 7.5–9.8
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (15)
Products and version ranges known to be affected.
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2024-0054IBM Security Verify Access: Mehrere SchwachstellenDeutsch2024-01-09csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in IBM Security Verify Access ausnutzen, um beliebigen Code auszuführen, Sicherheitsmaßnahmen zu umgehen, einen Denial-of-Service-Zustand herbeizuführen, vertrauliche Informationen offenzulegen, seine Privilegien zu erweitern oder komplexe Angriffe wie Cache Poisoning, Cross-Site-Scripting oder Session-Hijacking durchzuführen.
- WID-SEC-W-2024-1298F5 BIG-IP: Schwachstelle ermöglicht CodeausführungDeutsch2024-06-05csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in F5 BIG-IP ausnutzen, um beliebigen Programmcode auszuführen.
- GHSA-rprw-h62v-c2w7PyYAML insecurely deserializes YAML strings leading to arbitrary code execution2019-01-04ghsa · osvUS
In PyYAML before 5.1, the `yaml.load()` API could execute arbitrary code. In other words, `yaml.safe_load` is not used. This was intended to be fixed in 4.1, but due to [breaking changes](https://github.com/yaml/pyyaml/issues/192#issuecomment-401491470), 4.1 was yanked and 5.1 [contains](https://github.com/yaml/pyyaml/issues/207#issuecomment-472520007) the patch for CVE-2017-18342.
- PYSEC-2018-492018-06-27vendor · osvUS
In PyYAML before 5.1, the yaml.load() API could execute arbitrary code if used with untrusted data. The load() function has been deprecated in version 5.1 and the 'UnsafeLoader' has been introduced for backward compatibility with the function.
also known as (7)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (30)
External citations — patches, advisories, analysis.
- https://github.com/marshmallow-code/apispec/issues/278cnnvd
- https://github.com/yaml/pyyaml/blob/master/CHANGEScnnvd
- https://github.com/yaml/pyyaml/issues/193cnnvd
- https://github.com/yaml/pyyaml/pull/74cnnvd
- https://github.com/yaml/pyyaml/wiki/PyYAML-yaml.load(input)-Deprecationcnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/JEX7IPV5P2QJITAMA5Z63GQCZA5I6NVZ/cnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KSQQMRUQSXBSUXLCRD3TSZYQ7SEZRKCE/cnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/M6JCFGEIEOFMWWIXGHSELMKQDD4CV2BA/cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan