CVE-2016-1182
mediumpriority · track · 42EPSS 0.257 · 98 %ileDEEURUUSEPSS · scored 2026-10-27
ActionServlet.java in Apache Struts 1 1.x through 1.3.10 does not properly restrict the Validator configuration, which allows remote attackers to conduct cross-site scripting (XSS) attacks or cause a denial of service via crafted input, a related issue to CVE-2015-0899.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- FixedOpenClinic GAcisa_csaf_ot
OpenClinic GA has released an updated version to resolve these vulnerabilities, and recommend users upgrade to Version 5.170.5 or later.
https://sourceforge.net/projects/open-clinic/files/
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–critical · 6.4–9.4
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (29)
Products and version ranges known to be affected.
advisories (5)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2024-1277Oracle Fusion Middleware: Mehrere SchwachstellenDeutsch2017-04-18csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Oracle Fusion Middleware ausnutzen, um dadurch die Integrität, Vertraulichkeit und Verfügbarkeit zu gefährden.
- WID-SEC-W-2025-1212Oracle Communications Applications: Mehrere SchwachstellenDeutsch2019-04-16csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Oracle Communications Applications ausnutzen, um dadurch die Integrität, Vertraulichkeit und Verfügbarkeit zu gefährden.
- WID-SEC-W-2026-2751IBM InfoSphere Guardium: Mehrere SchwachstellenDeutsch2018-12-13csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in IBM InfoSphere Guardium ausnutzen, um dadurch die Integrität, Vertraulichkeit und Verfügbarkeit zu gefährden.
- GHSA-5ggr-mpgw-3mgxImproper Input Validation in Apache Struts2022-05-13ghsa · osvUS
ActionServlet.java in Apache Struts 1 1.x through 1.3.10 does not properly restrict the Validator configuration, which allows remote attackers to conduct cross-site scripting (XSS) attacks or cause a denial of service via crafted input, a related issue to CVE-2015-0899.
- ICSMA-20-184-01OpenClinic GA (Update B)2020-07-02icsa · cisa_csaf_otUS
Successful exploitation of these vulnerabilities could allow an attacker to bypass authentication, discover restricted information, view/manipulate restricted database information, and/or execute malicious code.
also known as (6)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (72)
External citations — patches, advisories, analysis.
- http://jvn.jp/en/jp/JVN65044642/index.htmlcnnvd
- http://jvndb.jvn.jp/jvndb/JVNDB-2016-000097cnnvd
- http://www.ibm.com/support/docview.wsscnnvd
- http://www.ibm.com/support/docview.wss?uid=ibm10879093cnnvd
- http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.htmlcnnvd
- http://www.oracle.com/technetwork/security-advisory/cpujul2016-2881720.htmlcnnvd
- http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.htmlcnnvd
- http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.htmlcnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan