CVE-2015-8857
highpriority · track · 40EPSS 0.036 · 89 %ileEURUUSEPSS · scored 2026-10-26
The uglify-js package before 2.4.24 for Node.js does not properly account for non-boolean values when rewriting boolean expressions, which might allow attackers to bypass security mechanisms or possibly have unspecified other impact by leveraging improperly rewritten Javascript.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · high–critical · 7.5–9.8
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (6)
Products and version ranges known to be affected.
advisories (1)
Vendor and ecosystem advisories describing this.
- GHSA-34r7-q49f-h37cIncorrect Handling of Non-Boolean Comparisons During Minification in uglify-js2017-10-24ghsa · osvUS
Versions of `uglify-js` prior to 2.4.24 are affected by a vulnerability which may cause crafted JavaScript to have altered functionality after minification. ## Recommendation Upgrade UglifyJS to version >= 2.4.24.
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (10)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2016/04/20/11cnnvd
- http://www.securityfocus.com/bid/96410cnnvd
- https://nodesecurity.io/advisories/39cnnvd
- https://www.securityfocus.com/bid/96410cnnvd
- http://www.openwall.com/lists/oss-security/2016/04/20/11enisa_euvd
- http://www.securityfocus.com/bid/96410enisa_euvd
- https://nodesecurity.io/advisories/39enisa_euvd
- http://www.openwall.com/lists/oss-security/2016/04/20/11Mailing ListThird Party Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan