CVE-2015-6835

highpriority · attend · 62EPSS 0.362 · 98 %ileexploit · functionalDEEURUUS
grimoire priorityP1 · Urgent
Exploitable?
Public exploit
2 exploits · functional
Likely / severe?
36.2% (98th) EPSS
CVSS 7.5 · high
Is it mine?
69 products
Check your exposure
Who says so?
5 sources
cnnvd · enisa_euvd · fstec_bdu · ads_tec_psirt

EPSS · scored 2026-10-27

The session deserializer in PHP before 5.4.45, 5.5.x before 5.5.29, and 5.6.x before 5.6.13 mishandles multiple php_var_unserialize calls, which allow remote attackers to execute arbitrary code or cause a denial of service (use-after-free) via crafted session content.

01

remediations

Vendor fix, mitigation, or workaround guidance, as published by each source.

A vendor fix is available.

  • Fixedads_tec_psirt

    Update firmware to the latest version available. The issues have been resolved with IRF1000 version 1.5.0, IRF2000 version 4.4.0 and IRF3000 version 1.2.0.

  • Mitigationads_tec_psirt

    It is recommended to disable all user accounts with restricted configuration write permissions if the update to the latest released version cannot be installed immediately.It is further recommended to use best practice password policies.

02

cvss

Technical severity, 0–10. One row per scoring source.

9.8
010

base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · high–critical · 7.5–9.8

v2.07.5highAV:N/AC:L/Au:N/C:P/I:P/A:Pprimary · NVD / NIST USexploitability 10 · impact 6.4
v3.09.8criticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:Hprimary · NVD / NIST USexploitability 3.9 · impact 5.9
v2.07.5highAV:N/AC:L/Au:N/C:P/I:P/A:Psecondary · FSTEC (BDU) RU
v3.09.8criticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:Hsecondary · CVSS-BT (t0sche)
v3.09.8criticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:Hsecondary · ads-tec PSIRT
03

weaknesses

The CWE weakness classes this flaw belongs to.

04

exploits (2)

Public proof-of-concept and weaponised exploit code.

05

affected products (69)

Products and version ranges known to be affected.

06

advisories (2)

Vendor and ecosystem advisories describing this.

  • VDE-2023-009ads-tec: Multiple Vulnerabilities in IRF1000, IRF2000 and IRF30002023-05-08csaf · ads_tec_psirtDE

    The affected products integrate the vulnerable libraries in a way so that the vulnerabilities can't be exploited remotely without prior authentication.

  • WID-SEC-W-2025-1425PHP: Mehrere SchwachstellenDeutsch2015-09-07csaf · cert_bundDE

    Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in PHP ausnutzen, um beliebigen Code mit den Rechten des Dienstes auszuführen, um einen Denial of Service Zustand hervorrufen oder um Informationen offenzulegen.

07

also known as (5)

Other names and identifiers for this entity.

08

sources

Which sources assert this record, and when.

09

references (15)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan