CVE-2014-3743
mediumpriority · track · 25EPSS 0.017 · 77 %ileEUUSEPSS · scored 2026-10-27
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (3)
Products and version ranges known to be affected.
advisories (1)
Vendor and ecosystem advisories describing this.
- GHSA-9cw2-jqp5-7x39Multiple Content Injection Vulnerabilities in marked2020-08-31ghsa · osvUS
Versions 0.3.0 and earlier of `marked` are affected by two cross-site scripting vulnerabilities, even when `sanitize: true` is set. The attack vectors for this vulnerability are GFM Codeblocks and JavaScript URLs. ## Recommendation Upgrade to version 0.3.1 or later.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (14)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2014/05/13/1cnnvd
- http://www.openwall.com/lists/oss-security/2014/05/15/2cnnvd
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2014-3743cnnvd
- https://github.com/chjj/marked/Patchcnnvd
- https://nodesecurity.io/advisories/marked_multiple_content_injection_vulnerabilitiescnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2014-3743cnnvd
- http://www.openwall.com/lists/oss-security/2014/05/13/1enisa_euvd
- http://www.openwall.com/lists/oss-security/2014/05/15/2enisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan