CVE-2005-3388

mediumpriority · track · 44EPSS 0.489 · 99 %ileexploit · functionalEUUS
grimoire priorityP1 · Urgent
Exploitable?
Public exploit
1 exploit · functional
Likely / severe?
48.9% (99th) EPSS
CVSS 4.3 · medium
Is it mine?
41 products
Check your exposure
Who says so?
3 sources
enisa_euvd · nvd · redhat_csaf

EPSS · scored 2026-10-24

Cross-site scripting (XSS) vulnerability in the phpinfo function in PHP 4.x up to 4.4.0 and 5.x up to 5.0.5 allows remote attackers to inject arbitrary web script or HTML via a crafted URL with a "stacked array assignment."

01

remediations

Vendor fix, mitigation, or workaround guidance, as published by each source.

A vendor fix is available.

  • FixedRed Hat Enterprise Linux AS (Advanced Server) version 2.1 redhat_csaf

    Before applying this update, make sure all previously released errata relevant to your system have been applied. This update is available via Red Hat Network. To use Red Hat Network, launch the Red Hat Update Agent with the following command: up2date This will start an interactive process that will result in the appropriate RPMs being upgraded on your system.

    https://access.redhat.com/errata/RHSA-2005:838
  • FixedRed Hat Enterprise Linux ES version 2.1redhat_csaf

    Before applying this update, make sure all previously released errata relevant to your system have been applied. This update is available via Red Hat Network. To use Red Hat Network, launch the Red Hat Update Agent with the following command: up2date This will start an interactive process that will result in the appropriate RPMs being upgraded on your system.

    https://access.redhat.com/errata/RHSA-2005:838
  • FixedRed Hat Enterprise Linux WS version 2.1redhat_csaf

    Before applying this update, make sure all previously released errata relevant to your system have been applied. This update is available via Red Hat Network. To use Red Hat Network, launch the Red Hat Update Agent with the following command: up2date This will start an interactive process that will result in the appropriate RPMs being upgraded on your system.

    https://access.redhat.com/errata/RHSA-2005:838
  • FixedRed Hat Linux Advanced Workstation 2.1redhat_csaf

    Before applying this update, make sure all previously released errata relevant to your system have been applied. This update is available via Red Hat Network. To use Red Hat Network, launch the Red Hat Update Agent with the following command: up2date This will start an interactive process that will result in the appropriate RPMs being upgraded on your system.

    https://access.redhat.com/errata/RHSA-2005:838
  • FixedRed Hat Stronghold 4redhat_csaf

    Updated Stronghold 4 packages containing backported patches to correct these issues are now available via the update agent service. Run the following command from the Stronghold 4 install root to upgrade an existing Stronghold 4 installation to the new package versions: $ bin/agent The Stronghold 4.0k patch release which contains these updated packages is also available from the download site. After upgrading Stronghold, the server must be completely restarted by running the following commands from the install root: $ bin/stop-server $ bin/start-server For more information on how to upgrade between releases of Stronghold 4, refer to http://stronghold.redhat.com/support/upgrade-sh4

    https://access.redhat.com/errata/RHSA-2005:882
02

cvss

Technical severity, 0–10. One row per scoring source.

4.3
010

base score 0–10 · higher = more severe · hover a vector to decode

v2.04.3mediumAV:N/AC:M/Au:N/C:N/I:P/A:Nprimary · NVD / NIST USexploitability 8.6 · impact 2.9
v2.04.3mediumAV:N/AC:M/Au:N/C:N/I:P/A:N/E:Hsecondary · CVSS-BT (t0sche)
03

weaknesses

The CWE weakness classes this flaw belongs to.

CWE-79USLLM-inferred
04

exploits (1)

Public proof-of-concept and weaponised exploit code.

05

affected products (41)

Products and version ranges known to be affected.

showing 20 of 41
06

advisories (2)

Vendor and ecosystem advisories describing this.

  • RHSA-2005:838Red Hat Security Advisory: php security update2005-11-10csaf · redhat_csafUS

    Updated PHP packages that fix multiple security issues are now available for Red Hat Enterprise Linux 2.1 This update has been rated as having moderate security impact by the Red Hat Security Response Team.

  • RHSA-2005:882Red Hat Security Advisory: openssl, php, mod_ssl, mod_imap security update for Stronghold2005-12-19csaf · redhat_csafUS

    Updated versions of cross-platform Stronghold that fix security issues in mod_ssl, mod_imap, OpenSSL, and PHP are now available. This update has been rated as having important security impact by the Red Hat Security Response Team.

07

also known as (2)

Other names and identifiers for this entity.

08

sources

Which sources assert this record, and when.

published 2005-11-01modified 2026-06-16
09

references (64)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan