CVE-2001-1246
highpriority · track · 43EPSS 0.097 · 96 %ileexploit · functionalEUUSEPSS · scored 2026-10-23
PHP 4.0.5 through 4.1.0 in safe mode does not properly cleanse the 5th parameter to the mail() function, which allows local users and possibly remote attackers to execute arbitrary commands via shell metacharacters.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- FixedRed Hat Enterprise Linux AS (Advanced Server) version 2.1 redhat_csaf
Please Note: The /etc/php.ini configuration file is not replaced or overwritten. You should carefully review your configuration file and adapt it to your server or service functions. Before applying this update, make sure all previously released errata relevant to your system have been applied. Please note that this update is available via Red Hat Network. To use Red Hat Network, launch the Red Hat Update Agent with the following command: up2date This will start an interactive process that will result in the appropriate RPMs being upgraded on your system.
https://access.redhat.com/errata/RHSA-2002:129 - FixedRed Hat Linux 7.1redhat_csaf
Before applying this update, make sure all previously released errata relevant to your system have been applied. To update all RPMs for your particular architecture, run: rpm -Fvh [filenames] where [filenames] is a list of the RPMs you wish to upgrade. Only those RPMs which are currently installed will be updated. Those RPMs which are not installed but included in the list will not be updated. Note that you can also use wildcards (*.rpm) if your current directory *only* contains the desired RPMs. Please note that this update is also available via Red Hat Network. Many people find this an easier way to apply updates. To use Red Hat Network, launch the Red Hat Update Agent with the following command: up2date This will start an interactive process that will result in the appropriate RPMs being upgraded on your system.
https://access.redhat.com/errata/RHSA-2003:159
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.8–7.5
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (1)
Public proof-of-concept and weaponised exploit code.
- EDB-20985PHP 4.x - SafeMode Arbitrary File Executionfunctional · exploit_db
affected products (4)
Products and version ranges known to be affected.
- Red Hat Enterprise Linux AS (Advanced Server) version 2.1 all versionsfixedredhat_csafUScpe:/o:redhat:enterprise_linux:2.1::as
advisories (2)
Vendor and ecosystem advisories describing this.
- RHSA-2002:129Red Hat Security Advisory: php security update2002-06-26csaf · redhat_csafUS
PHP versions earlier than 4.1.0 contain a vulnerability that could allow arbitrary commands to be executed. [updated 22 Aug 2002] The initial set of errata packages contained an incorrect set of dependencies. This meant that a number of packages would need to be installed before php that were not essential to the operation of php. Updated errata packages are included with this advisory that have corrected dependencies.
- RHSA-2003:159Red Hat Security Advisory: : : : New PHP packages fix vulnerabilities2003-06-30csaf · redhat_csafUS
Updated PHP packages are available for Red Hat Linux on IBM iSeries and pSeries systems.
also known as (2)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (14)
External citations — patches, advisories, analysis.
- http://online.securityfocus.com/archive/1/194425enisa_euvd
- http://www.iss.net/security_center/static/6787.phpenisa_euvd
- http://www.php.net/do_download.php?download_file=php-4.1.2.tar.gzenisa_euvd
- http://www.redhat.com/support/errata/RHSA-2002-102.htmlenisa_euvd
- http://www.redhat.com/support/errata/RHSA-2002-129.htmlenisa_euvd
- http://www.redhat.com/support/errata/RHSA-2003-159.htmlenisa_euvd
- http://www.securityfocus.com/bid/2954enisa_euvd
- http://online.securityfocus.com/archive/1/194425Broken LinkThird Party AdvisoryVDB Entrynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan