CVE-2026-59898
highPriorität · verfolgen · 30EPSS 0.004 · 37. PerzentilDEEUUSEPSS · bewertet 2026-10-22
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
Behebungen
Hersteller-Fix, Mitigation oder Workaround, wie von den Quellen veröffentlicht.
Ein Hersteller-Fix ist verfügbar.
- BehobenCorivaEnginesick_psirt
Users are recommended to upgrade to version 2026.1.1.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · low–high · 1.7–7.5
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (20)
Betroffene Produkte und Versionsbereiche.
- IBM App Connect Enterprise for Manufactoringalle Versionencert_bundDEcpe:/a:ibm:app_connect_enterprise:for_manufactoring
Advisories (3)
Hersteller- und Ökosystem-Meldungen dazu.
- WID-SEC-W-2026-2356Netty: Mehrere SchwachstellenDeutsch2026-07-14csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Netty ausnutzen, um Sicherheitsprüfungen zu umgehen, Anfragen oder Header zu manipulieren, Zertifikatsprüfungen zu unterlaufen sowie einen Denial of Service zu verursachen.
- sca-2026-0013Vulnerabilities Affecting SICK CorivaEngine2026-09-11csaf · sick_psirtDE
SICK CorivaEngine includes the third-party components Netty and Spring Cloud Gateway that are affected by multiple known vulnerabilities. Under certain conditions, these vulnerabilities could allow remote attackers to perform HTTP request smuggling, cause resource exhaustion, or manipulate forwarded request headers. Successful exploitation may impact the integrity and availability of affected systems. SICK has addressed these vulnerabilities and recommends that customers apply the remediations described in this Security Advisory.
- GHSA-4mp9-239f-g9hgNetty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation2026-07-22ghsa · osvUS
## Summary An attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks.
auch bekannt als (3)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (9)
Externe Belege — Patches, Meldungen, Analysen.
- https://github.com/netty/netty/releases/tag/netty-4.1.136.Finalcnnvd
- https://github.com/netty/netty/releases/tag/netty-4.2.16.Finalcnnvd
- https://github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hgcnnvd
- https://github.com/netty/netty/releases/tag/netty-4.1.136.Finalenisa_euvd
- https://github.com/netty/netty/releases/tag/netty-4.2.16.Finalenisa_euvd
- https://github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hgenisa_euvd
- https://github.com/netty/netty/releases/tag/netty-4.1.136.FinalRelease Notesnvd
- https://github.com/netty/netty/releases/tag/netty-4.2.16.FinalRelease Notesnvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan