CVE-2026-33762

lowPriorität · verfolgen · 0EPSS 0.002 · 4. PerzentilEUFRRUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
0.15% (4th) EPSS
CVSS 2.8 · low
Is it mine?
31 products
Prüfe deine Angriffsfläche
Who says so?
5 sources
cnnvd · enisa_euvd · fstec_bdu · osv

EPSS · bewertet 2026-10-27

go-git is an extensible git implementation library written in pure Go. Prior to version 5.17.1, go-git’s index decoder for format version 4 fails to validate the path name prefix length before applying it to the previously decoded path name. A maliciously crafted index file can trigger an out-of-bounds slice operation, resulting in a runtime panic during normal index parsing. This issue only affects Git index format version 4. Earlier formats (go-git supports only v2 and v3) are not vulnerable to this issue. This issue has been patched in version 5.17.1.

01

cvss

Technischer Schweregrad, 0–10. Eine Zeile je Quelle.

2.8
010

Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen

v3.12.8lowAV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:Lsecondary · FSTEC (BDU) RU
v3.12.8lowCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:Lsecondary · ENISA EU
v3.12.8lowCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:Lsecondary · security-advisories@github.comAusnutzbarkeit 1.3 · Auswirkung 1.4
v3.12.8lowCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:Lsecondary · OSV
v3.12.6lowCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L/E:Usecondary · CVSS-BT (t0sche)
02

SSVC

Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.

Trackcoordinatorcisa_ssvcUS
03

schwächen

Die CWE-Schwächeklassen, zu denen dies gehört.

04

betroffene Produkte (31)

Betroffene Produkte und Versionsbereiche.

05

Advisories (3)

Hersteller- und Ökosystem-Meldungen dazu.

  • GHSA-gm2x-2g9h-ccm8go-git missing validation decoding Index v4 files leads to panic2026-03-30ghsa · osvUS

    ### Impact `go-git`’s index decoder for format version 4 fails to validate the path name prefix length before applying it to the previously decoded path name. A maliciously crafted index file can trigger an out-of-bounds slice operation, resulting in a runtime panic during normal index parsing. This issue only affects Git index format version 4. Earlier formats (`go-git` supports only `v2` and `v3`) are not vulnerable to this issue. An attacker able to supply a crafted `.git/index` file can cause applications using go-git to panic while reading the index. If the application does not recover from panics, this results in process termination, leading to a denial-of-service (DoS) condition. Exploitation requires the ability to modify or inject a Git index file within the local repository in disk. This typically implies write access to the `.git` directory. ### Patches Users should upgrade to `v5.17.1`, or the latest `v6` [pseudo-version](https://go.dev/ref/mod#pseudo-versions), in order to mitigate this vulnerability. ### Credit go-git maintainers thank @kq5y for finding and reporting this issue privately to the `go-git` project.

  • CERTFR-2026-AVI-1385Multiples vulnérabilités dans les produits VMwareFrançais2026-10-26vendor · certfrFR
  • GO-2026-4909Missing validation decoding Index v4 files leads to panic in github.com/go-git/go-git2026-04-07vendor · osvUS

    Missing validation decoding Index v4 files leads to panic in github.com/go-git/go-git

06

auch bekannt als (5)

Weitere Namen und Kennungen dieser Entität.

07

quellen

Welche Quellen diesen Datensatz belegen und wann.

veröffentlicht 2026-03-31geändert 2026-08-05
08

Referenzen (7)

Externe Belege — Patches, Meldungen, Analysen.

scry

Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.

Kostenloser Scan