CVE-2026-30960
criticalPriorität · verfolgen · 0EPSS 0.002 · 10. PerzentilEUUSEPSS · bewertet 2026-10-27
rssn is a scientific computing library for Rust, combining a high-performance symbolic computation engine with numerical methods support and physics simulations functionalities. The vulnerability exists in the JIT (Just-In-Time) compilation engine, which is fully exposed via the CFFI (Foreign Function Interface). Due to Improper Input Validation and External Control of Code Generation, an attacker can supply malicious parameters or instruction sequences through the CFFI layer. Since the library often operates with elevated privileges or within high-performance computing contexts, this allows for Arbitrary Code Execution (ACE) at the privilege level of the host process.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · high–critical · 7.6–9.4
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (3)
Betroffene Produkte und Versionsbereiche.
Advisories (2)
Hersteller- und Ökosystem-Meldungen dazu.
- GHSA-9c4h-pwmf-m6fjRSSN has Arbitrary Code Execution via Unvalidated JIT Instruction Generation in C-FFI Interface2026-03-10ghsa · osvUS
## Impact **Vulnerability Type**: Improper Control of Generation of Code ('Code Injection') (CWE-94) / Improper Check for Unusual or Exceptional Conditions (CWE-754) / Improper Input Validation (CWE-20) / Use of Low-Level Functionality (CWE-695) / Improper Privilege Management (CWE-269) / External Control of System or Configuration Setting (CWE-15). **Technical Details**: The vulnerability exists in the JIT (Just-In-Time) compilation engine, which is fully exposed via the CFFI (Foreign Function Interface). Due to Improper Input Validation and External Control of Code Generation, an attacker can supply malicious parameters or instruction sequences through the CFFI layer. Since the library often operates with elevated privileges or within high-performance computing contexts, this allows for Arbitrary Code Execution (ACE) at the privilege level of the host process. ## Who is Impacted? * Developers using the library as a dynamic linked library (.so, .dll, .dylib) in multi-language environments (e.g., Python, Node.js, C++). * Cloud Service Providers running the library in multi-tenant environments or automated model-training pipelines. * Users processing untrusted or third-party datasets/models that may trigger malicious JIT instruction generation. Patches * Affected versions: < 0.2.8 * Patched version: 0.2.9 ## Workarounds If you cannot upgrade immediately, please consider the following mitigations: * Strict Sandboxing: Run the library within a restricted sandbox (e.g., WebAssembly, Docker with non-root user, or seccomp profiles) to limit system call access. * Principle of Least Privilege: Ensure the process calling the library does not have administrative or root privileges. * Input Filtering: If possible, implement an application-level validation layer to sanitize any data passed to the CFFI interfaces. * Disable JIT (if applicable): If your workload allows, use the interpreter-only mode (if provided by the library) to bypass the JIT engine entirely. CVSS Score * Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H * Base Score: 9.4 (Critical) ## References [Apich Organization Security Team Homepage](https://security.apich.org/)
- RUSTSEC-2026-0038RustSec Advisory2026-03-08vendor · osvUS
## Impact **Vulnerability Type**: Improper Control of Generation of Code ('Code Injection') (CWE-94) / Improper Check for Unusual or Exceptional Conditions (CWE-754) / Improper Input Validation (CWE-20) / Use of Low-Level Functionality (CWE-695) / Improper Privilege Management (CWE-269) / External Control of System or Configuration Setting (CWE-15). **Technical Details**: The vulnerability exists in the JIT (Just-In-Time) compilation engine, which is fully exposed via the CFFI (Foreign Function Interface). Due to Improper Input Validation and External Control of Code Generation, an attacker can supply malicious parameters or instruction sequences through the CFFI layer. Since the library often operates with elevated privileges or within high-performance computing contexts, this allows for Arbitrary Code Execution (ACE) at the privilege level of the host process. ## Who is Impacted? * Developers using the library as a dynamic linked library (.so, .dll, .dylib) in multi-language environments (e.g., Python, Node.js, C++). * Cloud Service Providers running the library in multi-tenant environments or automated model-training pipelines. * Users processing untrusted or third-party datasets/models that may trigger malicious JIT instruction generation. Patches * Affected versions: < 0.2.8 * Patched version: 0.2.9 ## Workarounds If you cannot upgrade immediately, please consider the following mitigations: * Strict Sandboxing: Run the library within a restricted sandbox (e.g., WebAssembly, Docker with non-root user, or seccomp profiles) to limit system call access. * Principle of Least Privilege: Ensure the process calling the library does not have administrative or root privileges. * Input Filtering: If possible, implement an application-level validation layer to sanitize any data passed to the CFFI interfaces. * Disable JIT (if applicable): If your workload allows, use the interpreter-only mode (if provided by the library) to bypass the JIT engine entirely. ## References [Apich Organization Security Team Homepage](https://security.apich.org/)
auch bekannt als (5)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (10)
Externe Belege — Patches, Meldungen, Analysen.
- https://github.com/Apich-Organization/rssn/releasesPatchcnnvd
- https://github.com/Apich-Organization/rssn/releases/tag/v0.2.9cnnvd
- https://github.com/Apich-Organization/rssn/security/advisories/GHSA-9c4h-pwmf-m6fjcnnvd
- https://rustsec.org/advisories/RUSTSEC-2026-0038.htmlcnnvd
- https://github.com/Apich-Organization/rssn/releases/tag/v0.2.9enisa_euvd
- https://github.com/Apich-Organization/rssn/security/advisories/GHSA-9c4h-pwmf-m6fjenisa_euvd
- https://rustsec.org/advisories/RUSTSEC-2026-0038.htmlenisa_euvd
- https://github.com/Apich-Organization/rssn/releases/tag/v0.2.9nvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan