CVE-2026-21893
highPriorität · verfolgen · 30EPSS 0.016 · 75. PerzentilDEEUNLUSEPSS · bewertet 2026-10-27
n8n is an open source workflow automation platform. From version 0.187.0 to before 1.120.3, a command injection vulnerability was identified in n8n’s community package installation functionality. The issue allowed authenticated users with administrative permissions to execute arbitrary system commands on the n8n host under specific conditions. This issue has been patched in version 1.120.3.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · high–critical · 7.2–9.4
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (10)
Betroffene Produkte und Versionsbereiche.
Advisories (3)
Hersteller- und Ökosystem-Meldungen dazu.
- NCSC-2026-0049Kwetsbaarheden verholpen in n8nNL2026-02-09csaf · ncsc_nlNL
n8n heeft kwetsbaarheden verholpen in versies 1.114.3, 1.115.0, 1.123.17, 2.5.2, 1.122.5, 1.123.2, 1.123.18, 2.5.0, 1.123.10, 2.5.0, 2.2.1, 1.123.9, 1.123.12, 2.4.0, 1.118.0, 2.4.0, 2.4.8, en 1.120.3.
- WID-SEC-W-2026-0318n8n: Mehrere SchwachstellenDeutsch2026-02-04csaf · cert_bundDE
Ein entfernter, authentisierter oder anonymer Angreifer kann mehrere Schwachstellen in n8n ausnutzen, um beliebigen Code auszuführen, sich erhöhte Berechtigungen zu verschaffen, Cross-Site-Scripting-Angriffe durchzuführen und vertrauliche Informationen offenzulegen. Über einige dieser Schwachstellen sind weitere Angriffe möglich, wie beispielsweise die Übernahme von Konten, das Hijacking von Sitzungen und die vollständige Kompromittierung des Systems.
- GHSA-7c4h-vh2m-743mn8n Vulnerable to Command Injection in Community Package Installation2026-02-04ghsa · osvUS
### Impact A Command Injection vulnerability was identified in n8n’s community package installation functionality. The issue allowed authenticated users with administrative permissions to execute arbitrary system commands on the n8n host under specific conditions. **Important context** - Exploitation requires _administrative_ access to the n8n instance. - The affected functionality is restricted to trusted users who are already permitted to install third-party community packages. - No unauthenticated or low-privilege exploitation is possible. - There is no evidence of exploitation in the wild. Because administrative users can already extend n8n with custom or community code, the vulnerability does not meaningfully expand the threat model beyond existing administrator capabilities. However, it represents a violation of secure coding practices and has therefore been addressed. ### Patches Users are advised to upgrade to n8n version 1.120.3 or later, which fully resolves the issue. As a general security best practice, n8n instance owners should ensure that: - Administrative access is limited to trusted users only. - Community packages are installed only from trusted sources. - Instances are kept up to date with the latest security releases.
auch bekannt als (3)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (8)
Externe Belege — Patches, Meldungen, Analysen.
- https://access.redhat.com/security/cve/cve-2026-21893cnnvd
- https://github.com/n8n-io/n8n/commit/ae0669a736cc496beeb296e115267862727ae838cnnvd
- https://github.com/n8n-io/n8n/releasesPatchcnnvd
- https://github.com/n8n-io/n8n/security/advisories/GHSA-7c4h-vh2m-743mcnnvd
- https://github.com/n8n-io/n8n/commit/ae0669a736cc496beeb296e115267862727ae838enisa_euvd
- https://github.com/n8n-io/n8n/security/advisories/GHSA-7c4h-vh2m-743menisa_euvd
- https://github.com/n8n-io/n8n/commit/ae0669a736cc496beeb296e115267862727ae838Patchnvd
- https://github.com/n8n-io/n8n/security/advisories/GHSA-7c4h-vh2m-743mVendor Advisorynvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan