CVE-2025-48912
mediumPriorität · verfolgen · 26EPSS 0.008 · 56. PerzentilDEEURUUSEPSS · bewertet 2026-10-27
An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · medium–high · 4.9–7.1
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (7)
Betroffene Produkte und Versionsbereiche.
Advisories (4)
Hersteller- und Ökosystem-Meldungen dazu.
- WID-SEC-W-2025-1168Apache Superset: Schwachstelle ermöglicht SQL InjectionDeutsch2025-05-29csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in Apache Superset ausnutzen, um eine SQL Injection durchzuführen, und somit Daten zu manipulieren.
- GHSA-8w7f-8pr9-xgwjApache Superset: Improper authorization bypass on row level security via SQL Injection2025-05-30ghsa · osvUS
An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.
- BIT-superset-2025-48912Apache Superset: Improper authorization bypass on row level security via SQL Injection2025-06-03vendor · osvUS
An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.
- PYSEC-2026-1164Apache Superset: Improper authorization bypass on row level security via SQL Injection2026-07-07vendor · osvUS
An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.
auch bekannt als (8)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (7)
Externe Belege — Patches, Meldungen, Analysen.
- http://www.openwall.com/lists/oss-security/2025/05/30/3cnnvd
- https://lists.apache.org/thread/ms2t2oq218hb7l628trsogo4fj7h1135cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2025-48912cnnvd
- https://superset.apache.org/Patchcnnvd
- https://lists.apache.org/thread/ms2t2oq218hb7l628trsogo4fj7h1135enisa_euvd
- http://www.openwall.com/lists/oss-security/2025/05/30/3Mailing Listnvd
- https://lists.apache.org/thread/ms2t2oq218hb7l628trsogo4fj7h1135Mailing Listnvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan