CVE-2025-24814
mediumPriorität · verfolgen · 22EPSS 0.012 · 67. PerzentilDEEURUUSEPSS · bewertet 2026-10-22
Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (17)
Betroffene Produkte und Versionsbereiche.
- IBM Operational Decision Manager 8.11.0.1alle Versionencert_bundDEcpe:/a:ibm:operational_decision_manager:8.11.0.1
- IBM Operational Decision Manager 8.11.1.0alle Versionencert_bundDEcpe:/a:ibm:operational_decision_manager:8.11.1.0
- IBM Operational Decision Manager 8.12.0.1alle Versionencert_bundDEcpe:/a:ibm:operational_decision_manager:8.12.0.1
- IBM Operational Decision Manager 9.0.0.1alle Versionencert_bundDEcpe:/a:ibm:operational_decision_manager:9.0.0.1
- IBM Operational Decision Manager 9.5.0.0alle Versionencert_bundDEcpe:/a:ibm:operational_decision_manager:9.5.0.0
- IBM Operational Decision Manager 9.5.0.1alle Versionencert_bundDEcpe:/a:ibm:operational_decision_manager:9.5.0.1
Advisories (4)
Hersteller- und Ökosystem-Meldungen dazu.
- WID-SEC-W-2025-0197Apache Solr: Mehrere SchwachstellenDeutsch2025-01-26csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in Apache Solr ausnutzen, um Dateien zu manipulieren oder seine Rechte zu erweitern.
- WID-SEC-W-2025-1560Oracle Communications Applications: Mehrere SchwachstellenDeutsch2025-07-15csaf · cert_bundDE
Ein entfernter, anonymer oder authentisierter Angreifer kann mehrere Schwachstellen in Oracle Communications Applications ausnutzen, um die Vertraulichkeit, Integrität und Verfügbarkeit zu gefährden.
- GHSA-68r2-fwcg-qpm8Apache Solr vulnerable to Execution with Unnecessary Privileges2025-01-27ghsa · osvUS
Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.
- BIT-solr-2025-24814Apache Solr: Core-creation with "trusted" configset can use arbitrary untrusted files2025-01-29vendor · osvUS
Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.
auch bekannt als (6)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (7)
Externe Belege — Patches, Meldungen, Analysen.
- http://www.openwall.com/lists/oss-security/2025/01/26/1cnnvd
- https://lists.apache.org/thread/gl291pn8x9f9n52ys5l0pc0b6qtf0qw1cnnvd
- https://www.oracle.com/security-alerts/cpujul2025.htmlcnnvd
- https://lists.apache.org/thread/gl291pn8x9f9n52ys5l0pc0b6qtf0qw1enisa_euvd
- http://www.openwall.com/lists/oss-security/2025/01/26/1Mailing ListThird Party Advisorynvd
- https://lists.apache.org/thread/gl291pn8x9f9n52ys5l0pc0b6qtf0qw1Mailing ListVendor Advisorynvd
- https://security.netapp.com/advisory/ntap-20250214-0002/Third Party Advisorynvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan