CVE-2024-6345
highPriorität · verfolgen · 1EPSS 0.019 · 80. PerzentilDEEUNLRUUSEPSS · bewertet 2026-10-22
A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.
Behebungen
Hersteller-Fix, Mitigation oder Workaround, wie von den Quellen veröffentlicht.
Ein Hersteller-Fix ist verfügbar.
- BehobenFirmware < 2025.0.2 installed on AXC F 1152phoenix_contact_psirt
Update to the latest 2025.0.2 Firmware Release. PHOENIX CONTACT recommends to always use an up-to-date version of the PLCnext Engineer.
- BehobenFirmware < 2025.0.2 installed on AXC F 2152phoenix_contact_psirt
Update to the latest 2025.0.2 Firmware Release. PHOENIX CONTACT recommends to always use an up-to-date version of the PLCnext Engineer.
- BehobenFirmware < 2025.0.2 installed on AXC F 3152phoenix_contact_psirt
Update to the latest 2025.0.2 Firmware Release. PHOENIX CONTACT recommends to always use an up-to-date version of the PLCnext Engineer.
- BehobenFirmware < 2025.0.2 installed on BPC 9102Sphoenix_contact_psirt
Update to the latest 2025.0.2 Firmware Release. PHOENIX CONTACT recommends to always use an up-to-date version of the PLCnext Engineer.
- BehobenFirmware < 2025.0.2 installed on RFC 4072Sphoenix_contact_psirt
Update to the latest 2025.0.2 Firmware Release. PHOENIX CONTACT recommends to always use an up-to-date version of the PLCnext Engineer.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (46)
Betroffene Produkte und Versionsbereiche.
Advisories (13)
Hersteller- und Ökosystem-Meldungen dazu.
- NCSC-2024-0417Kwetsbaarheden verholpen in Oracle Fusion MiddlewareNL2024-10-17csaf · ncsc_nlNL
Oracle heeft kwetsbaarheden verholpen in Fusion Middleware componenten, zoals WebLogic Server, WebCenter en HTTP Server.
- VDE-2025-053Phoenix Contact: Multiple Vulnerabilities in PLCnext Firmware2025-07-08csaf · phoenix_contact_psirtDE
Multiple Linux component vulnerabilities fixed in latest PLCnext Firmware release 2025.0.2
- WID-SEC-W-2024-1756Red Hat Enterprise Linux (python-setuptools): Schwachstelle ermöglicht CodeausführungDeutsch2024-08-04csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann eine Schwachstelle in Red Hat Enterprise Linux ausnutzen, um beliebigen Programmcode auszuführen.
- WID-SEC-W-2024-1802IBM Business Automation Workflow: Mehrere SchwachstellenDeutsch2024-08-08csaf · cert_bundDE
Ein entfernter Angreifer kann mehrere Schwachstellen in IBM Business Automation Workflow ausnutzen, um Informationen offenzulegen oder beliebigen Code auszuführen.
- WID-SEC-W-2024-1815IBM VIOS und AIX: Mehrere SchwachstellenDeutsch2024-08-12csaf · cert_bundDE
Ein entfernter Angreifer oder ein Angreifer aus einem angrenzenden Netzwerk kann mehrere Schwachstellen in IBM VIOS und IBM AIX ausnutzen, um Informationen offenzulegen oder um beliebigen Code auszuführen.
- WID-SEC-W-2024-1913Red Hat OpenShift Container Platform: Mehrere SchwachstellenDeutsch2024-08-22csaf · cert_bundDE
Ein entfernter anonymer oder lokaler Angreifer kann mehrere Schwachstellen in Red Hat OpenShift Container Platform ausnutzen, um seine Privilegien zu erhöhen, beliebigen Code auszuführen, einen Denial-of-Service-Zustand zu erzeugen, vertrauliche Informationen offenzulegen, Dateien und Daten zu manipulieren oder Sicherheitsmaßnahmen zu umgehen.
- WID-SEC-W-2024-3191Oracle Fusion Middleware: Mehrere SchwachstellenDeutsch2024-10-15csaf · cert_bundDE
Ein entfernter, anonymer oder authentisierter Angreifer kann mehrere Schwachstellen in Oracle Fusion Middleware ausnutzen, um die Vertraulichkeit, Integrität und Verfügbarkeit zu gefährden.
- WID-SEC-W-2025-0001IBM DB2: Mehrere SchwachstellenDeutsch2025-01-01csaf · cert_bundDE
Ein entfernter oder lokaler Angreifer kann mehrere Schwachstellen in IBM DB2 on Cloud Pak for Data ausnutzen, um seine Privilegien zu erhöhen, beliebigen Code auszuführen, vertrauliche Informationen offenzulegen, Sicherheitsmaßnahmen zu umgehen oder einen Denial-of-Service-Zustand zu erzeugen.
- WID-SEC-W-2025-0225Dell PowerProtect Data Domain: Mehrere SchwachstellenDeutsch2025-01-30csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Dell PowerProtect Data Domain ausnutzen, um erhöhte Rechte zu erlangen, einen Denial-of-Service-Zustand herbeizuführen und einen nicht näher spezifizierten Angriff durchzuführen.
- WID-SEC-W-2026-0778Dell Secure Connect Gateway Policy Manager: Mehrere SchwachstellenDeutsch2026-03-18csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Dell Secure Connect Gateway Policy Manager ausnutzen, um einen nicht näher spezifizierten Angriff durchzuführen.
- GHSA-cx63-2mw6-8hw5setuptools vulnerable to Command Injection via package URL2024-07-15ghsa · osvUS
A vulnerability in the `package_index` module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.
- BIT-setuptools-2024-6345Remote Code Execution in pypa/setuptools2024-08-03vendor · osvUS
A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.
- PYSEC-2026-1918setuptools vulnerable to Command Injection via package URL2026-07-07vendor · osvUS
A vulnerability in the `package_index` module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.
auch bekannt als (8)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (12)
Externe Belege — Patches, Meldungen, Analysen.
- https://access.redhat.com/security/cve/cve-2024-6345cnnvd
- https://cxsecurity.com/cveshow/CVE-2024-6345/cnnvd
- https://github.com/pypa/setuptools/commit/88807c7062788254f654ea8c03427adc859321f0cnnvd
- https://github.com/pypa/setuptools/releases/tag/v70.3.0Patchcnnvd
- https://huntr.com/bounties/d6362117-ad57-4e83-951f-b8141c6e7ca5cnnvd
- https://vigilance.fr/vulnerability/python-setuptools-code-execution-via-package-index-44867cnnvd
- https://www.oracle.com/security-alerts/cpuoct2024.htmlcnnvd
- https://github.com/pypa/setuptools/commit/88807c7062788254f654ea8c03427adc859321f0enisa_euvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan