CVE-2024-45772
highPriorität · verfolgen · 32EPSS 0.006 · 48. PerzentilDEEUFRNLUSEPSS · bewertet 2026-10-27
Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator. This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected. Users are recommended to upgrade to version 9.12.0, which fixes the issue. The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · medium–high · 5.1–8
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (8)
Betroffene Produkte und Versionsbereiche.
- Maven org.apache.lucene:lucene-replicator4.4.0 → 9.12.0osvUSpkg:maven/org.apache.lucene/lucene-replicator
Advisories (4)
Hersteller- und Ökosystem-Meldungen dazu.
- NCSC-2025-0020Kwetsbaarheden verholpen in Oracle Database productenNL2025-01-22csaf · ncsc_nlNL
Oracle heeft kwetsbaarheden verholpen in diverse database producten en subsystemen, zoals de Core Database, Graal, Application Express, GoldenGate en REST data.
- WID-SEC-W-2024-3049Apache Lucene Replicator: Schwachstelle ermöglicht nicht spezifizierten AngriffDeutsch2024-09-29csaf · cert_bundDE
Ein Angreifer kann eine Schwachstelle in Apache Lucene Replicator ausnutzen, um einen nicht näher spezifizierten Angriff durchzuführen.
- GHSA-g643-xq6w-r67cDeserialization of Untrusted Data vulnerability in Apache Lucene Replicator.2024-09-30ghsa · osvUS
This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected. Users are recommended to upgrade to version 9.12.0, which fixes the issue. The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.
- CERTFR-2026-AVI-1385Multiples vulnérabilités dans les produits VMwareFrançais2026-10-26vendor · certfrFR
auch bekannt als (3)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (6)
Externe Belege — Patches, Meldungen, Analysen.
- http://www.openwall.com/lists/oss-security/2024/09/29/1cnnvd
- https://cxsecurity.com/cveshow/CVE-2024-45772/cnnvd
- https://lists.apache.org/thread/3f3oph7bqnqspb9q5p0gm5mgc1b6thjocnnvd
- https://lists.apache.org/thread/3f3oph7bqnqspb9q5p0gm5mgc1b6thjoenisa_euvd
- http://www.openwall.com/lists/oss-security/2024/09/29/1Third Party Advisorynvd
- https://lists.apache.org/thread/3f3oph7bqnqspb9q5p0gm5mgc1b6thjoMailing ListMitigationVendor Advisorynvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan