CVE-2024-27135
criticalPriorität · verfolgen · 42EPSS 0.060 · 93. PerzentilEURUUSEPSS · bewertet 2026-10-27
Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · high–critical · 8.5–9.9
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (21)
Betroffene Produkte und Versionsbereiche.
- Maven org.apache.pulsar:pulsar-functions-worker2.11.0 → 2.11.4osvUSpkg:maven/org.apache.pulsar/pulsar-functions-worker
- Maven org.apache.pulsar:pulsar-functions-worker2.4.0 → 2.10.6osvUSpkg:maven/org.apache.pulsar/pulsar-functions-worker
- Maven org.apache.pulsar:pulsar-functions-worker3.0.0 → 3.0.3osvUSpkg:maven/org.apache.pulsar/pulsar-functions-worker
- Maven org.apache.pulsar:pulsar-functions-worker3.1.0 → 3.1.3osvUSpkg:maven/org.apache.pulsar/pulsar-functions-worker
Advisories (1)
Hersteller- und Ökosystem-Meldungen dazu.
- GHSA-xp2r-g8qq-44hhApache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution2024-03-12ghsa · osvUS
Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
auch bekannt als (4)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (12)
Externe Belege — Patches, Meldungen, Analysen.
- http://www.openwall.com/lists/oss-security/2024/03/12/9cnnvd
- https://access.redhat.com/security/cve/cve-2024-27135cnnvd
- https://cxsecurity.com/cveshow/CVE-2024-27135/cnnvd
- https://lists.apache.org/thread/dh8nj2vmb2br6thjltq74lk9jxkz62wncnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2024-27135cnnvd
- https://pulsar.apache.org/security/CVE-2024-27135/cnnvd
- http://www.openwall.com/lists/oss-security/2024/03/12/9enisa_euvd
- https://lists.apache.org/thread/dh8nj2vmb2br6thjltq74lk9jxkz62wnenisa_euvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan