CVE-2024-24773
mediumPriorität · verfolgen · 26OT-Risiko · erhöhtEPSS 0.008 · 56. PerzentilDEEUUSEPSS · bewertet 2026-10-27
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (8)
Betroffene Produkte und Versionsbereiche.
Advisories (4)
Hersteller- und Ökosystem-Meldungen dazu.
- WID-SEC-W-2024-0515Apache Superset: Mehrere Schwachstellen ermöglichen Manipulation von DateienDeutsch2024-02-28csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in Apache Superset ausnutzen, um Dateien zu manipulieren.
- GHSA-5474-f7g5-273qApache Superset: Improper validation of SQL statements allows for unauthorized access to data2024-02-28ghsa · osvUS
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.
- BIT-superset-2024-24773Apache Superset: Improper validation of SQL statements allows for unauthorized access to data2025-02-05vendor · osvUS
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.
- PYSEC-2026-1160Apache Superset: Improper validation of SQL statements allows for unauthorized access to data2026-07-07vendor · osvUS
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.
auch bekannt als (7)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (7)
Externe Belege — Patches, Meldungen, Analysen.
- http://www.openwall.com/lists/oss-security/2024/02/28/4cnnvd
- https://cxsecurity.com/cveshow/CVE-2024-24773/cnnvd
- https://lists.apache.org/thread/h66fy6nj41cfx07zh7l552w6dmtjh501cnnvd
- http://www.openwall.com/lists/oss-security/2024/02/28/4enisa_euvd
- https://lists.apache.org/thread/h66fy6nj41cfx07zh7l552w6dmtjh501enisa_euvd
- http://www.openwall.com/lists/oss-security/2024/02/28/4Mailing ListThird Party Advisorynvd
- https://lists.apache.org/thread/h66fy6nj41cfx07zh7l552w6dmtjh501Mailing ListVendor Advisorynvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan