CVE-2024-24772
mediumPriorität · verfolgen · 17EPSS 0.010 · 61. PerzentilDEEUUSEPSS · bewertet 2026-10-27
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (8)
Betroffene Produkte und Versionsbereiche.
Advisories (4)
Hersteller- und Ökosystem-Meldungen dazu.
- WID-SEC-W-2024-0515Apache Superset: Mehrere Schwachstellen ermöglichen Manipulation von DateienDeutsch2024-02-28csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in Apache Superset ausnutzen, um Dateien zu manipulieren.
- GHSA-m6jm-3v38-76j4Apache Superset: Improper Neutralization of custom SQL on embedded context2024-02-28ghsa · osvUS
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
- BIT-superset-2024-24772Apache Superset: Improper Neutralisation of custom SQL on embedded context2025-02-05vendor · osvUS
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
- PYSEC-2026-1185Apache Superset: Improper Neutralization of custom SQL on embedded context2026-07-07vendor · osvUS
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
auch bekannt als (7)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (7)
Externe Belege — Patches, Meldungen, Analysen.
- http://www.openwall.com/lists/oss-security/2024/02/28/5cnnvd
- https://access.redhat.com/security/cve/cve-2024-24772cnnvd
- https://cxsecurity.com/cveshow/CVE-2024-24772/cnnvd
- https://lists.apache.org/thread/gfl3ckwy6y9tpz9jmpv62orh2q346sn5cnnvd
- https://lists.apache.org/thread/gfl3ckwy6y9tpz9jmpv62orh2q346sn5enisa_euvd
- http://www.openwall.com/lists/oss-security/2024/02/28/5Mailing ListThird Party Advisorynvd
- https://lists.apache.org/thread/gfl3ckwy6y9tpz9jmpv62orh2q346sn5Mailing ListVendor Advisorynvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan