CVE-2024-23635
mediumPriorität · verfolgen · 24EPSS 0.004 · 30. PerzentilDEEUNLRUUSEPSS · bewertet 2026-10-27
AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to 1.7.5, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. Patched in AntiSamy 1.7.5 and later.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (28)
Betroffene Produkte und Versionsbereiche.
- Oracle Fusion Middleware 12.2.1.3.0alle Versionencert_bundDEcpe:/a:oracle:fusion_middleware:12.2.1.3.0
- Oracle Fusion Middleware 12.2.1.4.0alle Versionencert_bundDEcpe:/a:oracle:fusion_middleware:12.2.1.4.0
- Oracle Fusion Middleware 14.1.1.0.0alle Versionencert_bundDEcpe:/a:oracle:fusion_middleware:14.1.1.0.0
- Oracle Fusion Middleware 14.1.2.0.0alle Versionencert_bundDEcpe:/a:oracle:fusion_middleware:14.1.2.0.0
- business_activity_monitoringalle Versionenncsc_nlNLcpe:2.3:a:oracle:business_activity_monitoring:12.2.1.4.0:*:*:*:*:*:*:*
- fusion_middleware_mapvieweralle Versionenncsc_nlNLcpe:2.3:a:oracle:fusion_middleware_mapviewer:12.2.1.4.0:*:*:*:*:*:*:*
- managed_file_transferalle Versionenncsc_nlNLcpe:2.3:a:oracle:managed_file_transfer:12.2.1.4.0:*:*:*:*:*:*:*
- middleware_common_libraries_and_toolsalle Versionenncsc_nlNLcpe:2.3:a:oracle:middleware_common_libraries_and_tools:12.2.1.4.0:*:*:*:*:*:*:*
Advisories (8)
Hersteller- und Ökosystem-Meldungen dazu.
- NCSC-2025-0027Kwetsbaarheden verholpen in Oracle Fusion MiddlewareNL2025-01-22csaf · ncsc_nlNL
Oracle heeft meerdere kwetsbaarheden verholpen in zijn producten, waaronder Oracle Fusion Middleware, Oracle WebLogic Server, en Oracle HTTP Server.
- WID-SEC-W-2024-0873Oracle Financial Services Applications: Mehrere SchwachstellenDeutsch2024-04-16csaf · cert_bundDE
Ein entfernter, anonymer oder authentisierter Angreifer kann mehrere Schwachstellen in Oracle Financial Services Applications ausnutzen, um die Vertraulichkeit, Integrität und Verfügbarkeit zu gefährden.
- WID-SEC-W-2024-0899Oracle Fusion Middleware: Mehrere SchwachstellenDeutsch2024-04-16csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Oracle Fusion Middleware ausnutzen, um die Vertraulichkeit, Integrität und Verfügbarkeit zu gefährden.
- WID-SEC-W-2024-1069IBM Maximo Asset Management: Schwachstelle ermöglicht Cross-Site ScriptingDeutsch2024-05-07csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann eine Schwachstelle in IBM Maximo Asset Management ausnutzen, um einen Cross-Site Scripting Angriff durchzuführen.
- WID-SEC-W-2024-1659Oracle Insurance Applications: Mehrere SchwachstellenDeutsch2024-07-16csaf · cert_bundDE
Ein entfernter, anonymer oder authentisierter Angreifer kann mehrere Schwachstellen in Oracle Insurance Applications ausnutzen, um die Vertraulichkeit, Integrität und Verfügbarkeit zu gefährden.
- WID-SEC-W-2024-3218Oracle Systems: Mehrere SchwachstellenDeutsch2024-10-15csaf · cert_bundDE
Ein entfernter, anonymer oder authentisierter Angreifer kann mehrere Schwachstellen in Oracle Systems ausnutzen, um die Vertraulichkeit, Integrität und Verfügbarkeit zu gefährden.
- WID-SEC-W-2025-0143Oracle Fusion Middleware: Mehrere SchwachstellenDeutsch2025-01-21csaf · cert_bundDE
Ein entfernter, anonymer oder authentisierter Angreifer kann mehrere Schwachstellen in Oracle Fusion Middleware ausnutzen, um die Vertraulichkeit, Integrität und Verfügbarkeit zu gefährden.
- GHSA-2mrq-w8pv-5pvqMalicious input can provoke XSS when preserving comments2024-02-02ghsa · osvUS
# Impact There is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. # Patches Patched in AntiSamy 1.7.5 and later. This is due to parsing behavior in the [neko-htmlunit](https://github.com/HtmlUnit/htmlunit-neko) dependency, just by updating to a newer version the issue was solved. See important remediation details in the reference given below. # Workarounds If you cannot upgrade to a fixed version of the library, the following mitigation can be applied until you can upgrade: Manually edit your AntiSamy policy file (e.g., antisamy.xml) by deleting the `preserveComments` directive or setting its value to `false`, if present. As the previously mentioned policy settings are preconditions for the mXSS attack to work, changing them as recommended should be sufficient to protect you against this vulnerability when using a vulnerable version of this library. However, the existing bug would still be present in the parser dependency (neko-htmlunit) and therefore in AntiSamy. The safety of this workaround relies on configurations that may change in the future and don't address the root cause of the vulnerability. As such, it is strongly recommended to upgrade to a fixed version of AntiSamy. # For more information If you have any questions or comments about this advisory: Email one of the project co-leaders, listed on the [OWASP AntiSamy project](https://owasp.org/www-project-antisamy/) page, under "Leaders".
auch bekannt als (4)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (9)
Externe Belege — Patches, Meldungen, Analysen.
- https://cxsecurity.com/cveshow/CVE-2024-23635/cnnvd
- https://github.com/nahsra/antisamy/releases/tag/v1.7.5Patchcnnvd
- https://github.com/nahsra/antisamy/security/advisories/GHSA-2mrq-w8pv-5pvqcnnvd
- https://www.oracle.com/security-alerts/cpuapr2024.htmlcnnvd
- https://www.oracle.com/security-alerts/cpujan2025.htmlcnnvd
- https://www.oracle.com/security-alerts/cpujul2024.htmlcnnvd
- https://www.oracle.com/security-alerts/cpuoct2024.htmlcnnvd
- https://github.com/nahsra/antisamy/security/advisories/GHSA-2mrq-w8pv-5pvqenisa_euvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan