CVE-2024-21910
mediumPriorität · verfolgen · 24EPSS 0.010 · 61. PerzentilEUUSEPSS · bewertet 2026-10-27
TinyMCE versions before 5.10.0 are affected by a cross-site scripting vulnerability. A remote and unauthenticated attacker could introduce crafted image or link URLs that would result in the execution of arbitrary JavaScript in an editing user's browser.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (5)
Betroffene Produkte und Versionsbereiche.
Advisories (2)
Hersteller- und Ökosystem-Meldungen dazu.
- GHSA-r8hm-w5f7-wj39Cross-site scripting vulnerability in TinyMCE plugins2021-11-02ghsa · osvUS
### Impact A cross-site scripting (XSS) vulnerability was discovered in the URL processing logic of the `image` and `link` plugins. The vulnerability allowed arbitrary JavaScript execution when updating an image or link using a specially crafted URL. This issue only impacted users while editing and the dangerous URLs were stripped in any content extracted from the editor. This impacts all users who are using TinyMCE 5.9.2 or lower. ### Patches This vulnerability has been patched in TinyMCE 5.10.0 by improved sanitization logic when updating URLs in the relevant plugins. ### Workarounds To work around this vulnerability, either: - Upgrade to TinyMCE 5.10.0 or higher - Disable the `image` and `link` plugins ### Acknowledgements Tiny Technologies would like to thank Yakir6 for discovering this vulnerability. ### References https://www.tiny.cloud/docs/release-notes/release-notes510/#securityfixes ### For more information If you have any questions or comments about this advisory: * Email us at [infosec@tiny.cloud](mailto:infosec@tiny.cloud) * Open an issue in the [TinyMCE repo](https://github.com/tinymce/tinymce/issues)
- PYSEC-2026-632Cross-site scripting vulnerability in TinyMCE plugins2026-07-02vendor · osvUS
### Impact A cross-site scripting (XSS) vulnerability was discovered in the URL processing logic of the `image` and `link` plugins. The vulnerability allowed arbitrary JavaScript execution when updating an image or link using a specially crafted URL. This issue only impacted users while editing and the dangerous URLs were stripped in any content extracted from the editor. This impacts all users who are using TinyMCE 5.9.2 or lower. ### Patches This vulnerability has been patched in TinyMCE 5.10.0 by improved sanitization logic when updating URLs in the relevant plugins. ### Workarounds To work around this vulnerability, either: - Upgrade to TinyMCE 5.10.0 or higher - Disable the `image` and `link` plugins ### Acknowledgements Tiny Technologies would like to thank Yakir6 for discovering this vulnerability. ### References https://www.tiny.cloud/docs/release-notes/release-notes510/#securityfixes ### For more information If you have any questions or comments about this advisory: * Email us at [infosec@tiny.cloud](mailto:infosec@tiny.cloud) * Open an issue in the [TinyMCE repo](https://github.com/tinymce/tinymce/issues)
auch bekannt als (6)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (20)
Externe Belege — Patches, Meldungen, Analysen.
- https://access.redhat.com/security/cve/cve-2024-21910cnnvd
- https://cxsecurity.com/cveshow/CVE-2024-21910/cnnvd
- https://github.com/advisories/GHSA-r8hm-w5f7-wj39cnnvd
- https://github.com/jazzband/django-tinymce/issues/366cnnvd
- https://github.com/jazzband/django-tinymce/releases/tag/3.4.0cnnvd
- https://github.com/tinymce/tinymce/security/advisories/GHSA-r8hm-w5f7-wj39cnnvd
- https://pypi.org/project/django-tinymce/3.4.0/cnnvd
- https://vulncheck.com/advisories/vc-advisory-GHSA-r8hm-w5f7-wj39cnnvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan