CVE-2023-51437
highPriorität · verfolgen · 30EPSS 0.008 · 55. PerzentilEURUUSEPSS · bewertet 2026-10-28
Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · medium–high · 6.8–7.4
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (16)
Betroffene Produkte und Versionsbereiche.
- Maven org.apache.pulsar:pulsar-broker-auth-sasl< 2.11.3osvUSpkg:maven/org.apache.pulsar/pulsar-broker-auth-sasl
- Maven org.apache.pulsar:pulsar-broker-auth-sasl3.0.0 → 3.0.2osvUSpkg:maven/org.apache.pulsar/pulsar-broker-auth-sasl
- Maven org.apache.pulsar:pulsar-broker-auth-sasl3.1.0 → 3.1.1osvUSpkg:maven/org.apache.pulsar/pulsar-broker-auth-sasl
Advisories (1)
Hersteller- und Ökosystem-Meldungen dazu.
- GHSA-c57v-4vg5-cm2xApache Pulsar SASL Authentication Provider observable timing discrepancy vulnerability2024-02-07ghsa · osvUS
Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .
auch bekannt als (4)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (8)
Externe Belege — Patches, Meldungen, Analysen.
- http://www.openwall.com/lists/oss-security/2024/02/07/1cnnvd
- https://cxsecurity.com/cveshow/CVE-2023-51437/cnnvd
- https://lists.apache.org/thread/5kgmvvolf5tzp5rz9xjwfg2ncwvqqgl5cnnvd
- https://www.openwall.com/lists/oss-security/2024/02/07/1cnnvd
- https://lists.apache.org/thread/5kgmvvolf5tzp5rz9xjwfg2ncwvqqgl5enisa_euvd
- https://www.openwall.com/lists/oss-security/2024/02/07/1enisa_euvd
- https://lists.apache.org/thread/5kgmvvolf5tzp5rz9xjwfg2ncwvqqgl5Issue TrackingVendor Advisorynvd
- https://www.openwall.com/lists/oss-security/2024/02/07/1nvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan