CVE-2023-47248
criticalPriorität · beachten · 54EPSS 0.145 · 97. PerzentilExploit · PoCDEEUNLRUUSEPSS · bewertet 2026-10-27
Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files). This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings. It is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon. If it is not possible to upgrade, we provide a separate package `pyarrow-hotfix` that disables the vulnerability on older PyArrow versions. See https://pypi.org/project/pyarrow-hotfix/ for instructions.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
Exploits (1)
Öffentlicher Proof-of-Concept- und Exploit-Code.
betroffene Produkte (76)
Betroffene Produkte und Versionsbereiche.
- Oracle Financial Services Applications 14.4.0.0.0alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:14.4.0.0.0
- Oracle Financial Services Applications 14.5.0.0.0alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:14.5.0.0.0
- Oracle Financial Services Applications 14.6.0.0.0alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:14.6.0.0.0
- Oracle Financial Services Applications 14.7.0.0.0alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:14.7.0.0.0
- Oracle Financial Services Applications 2.12.0.0.0alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:2.12.0.0.0
- Oracle Financial Services Applications 2.4.0.0.0alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:2.4.0.0.0
- Oracle Financial Services Applications 2.7.0.0.0alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:2.7.0.0.0
- Oracle Financial Services Applications 6.0.0.0.0alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:6.0.0.0.0
- Oracle Financial Services Applications 6.1.0.0.0alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:6.1.0.0.0
- Oracle Financial Services Applications 8.0.7alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:8.0.7
- Oracle Financial Services Applications 8.0.7.3alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:8.0.7.3
- Oracle Financial Services Applications 8.0.8alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:8.0.8
- Oracle Financial Services Applications 8.0.8.0alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:8.0.8.0
- Oracle Financial Services Applications 8.0.8.1alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:8.0.8.1
- Oracle Financial Services Applications 8.0.8.2.8alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:8.0.8.2.8
- Oracle Financial Services Applications 8.0.8.3alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:8.0.8.3
- Oracle Financial Services Applications 8.1.1alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:8.1.1
- Oracle Financial Services Applications 8.1.1.1alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:8.1.1.1
- Oracle Financial Services Applications 8.1.1.1.18alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:8.1.1.1.18
- Oracle Financial Services Applications 8.1.2alle Versionencert_bundDEcpe:/a:oracle:financial_services_applications:8.1.2
Advisories (4)
Hersteller- und Ökosystem-Meldungen dazu.
- NCSC-2024-0297 Kwetsbaarheden verholpen in Oracle Financial Services ApplicationsNL2024-07-17csaf · ncsc_nlNL
Er zijn kwetsbaarheden verholpen in Oracle Financial Services Applications.
- WID-SEC-W-2024-1638Oracle Financial Services Applications: Mehrere SchwachstellenDeutsch2024-07-16csaf · cert_bundDE
Ein entfernter, anonymer oder authentisierter Angreifer kann mehrere Schwachstellen in Oracle Financial Services Applications ausnutzen, um die Vertraulichkeit, Integrität und Verfügbarkeit zu gefährden.
- GHSA-5wvp-7f3h-6wmmPyArrow: Arbitrary code execution when loading a malicious data file2023-11-09ghsa · osvUS
Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files). This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings. It is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon. If it is not possible to upgrade, maintainers provide a separate package `pyarrow-hotfix` that disables the vulnerability on older PyArrow versions. See https://pypi.org/project/pyarrow-hotfix/ for instructions.
- PYSEC-2023-2382023-11-17vendor · osvUS
Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files).
auch bekannt als (7)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (21)
Externe Belege — Patches, Meldungen, Analysen.
- https://cxsecurity.com/cveshow/CVE-2023-47248/cnnvd
- https://github.com/apache/arrow/commit/f14170976372436ec1d03a724d8d3f3925484ecfcnnvd
- https://lists.apache.org/thread/yhy7tdfjf9hrl9vfrtzo8p2cyjq87v7ncnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FR34AIPXVTMB3XPRU5ULV5HHWPMRE33X/cnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MAGWEAJDWO2ACYATUQCPXLSYY5C3L3XU/cnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MWFYXLVBTBHNKYRXI572RFX7IJDDQGBL/cnnvd
- https://pypi.org/project/pyarrow-hotfix/cnnvd
- https://vigilance.fr/vulnerability/PyArrow-code-execution-via-IPC-Parquet-Readers-Deserialization-42980cnnvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan