CVE-2023-39418
mediumPriorität · verfolgen · 17OT-Risiko · erhöhtEPSS 0.011 · 65. PerzentilDEEURUUSEPSS · bewertet 2026-10-27
A vulnerability was found in PostgreSQL with the use of the MERGE command, which fails to test new rows against row security policies defined for UPDATE and SELECT. If UPDATE and SELECT policies forbid some rows that INSERT policies do not forbid, a user could store such rows.
Behebungen
Hersteller-Fix, Mitigation oder Workaround, wie von den Quellen veröffentlicht.
Ein Hersteller-Fix ist verfügbar.
- BehobenSINEC NMSsiemens_psirt
Update to V2.0 SP1 or later version
https://support.industry.siemens.com/cs/ww/en/view/109826954/ - BehobenSINEC NMScisa_csaf_ot
Update to V2.0 SP1 or later version
https://support.industry.siemens.com/cs/ww/en/view/109826954/
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · low–medium · 3.1–4.3
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (30)
Betroffene Produkte und Versionsbereiche.
- Red Hat Red Hat Enterprise Linux 8.8 Extended Update Support< 8080020231113134015.63b34585enisa_euvdEU
Advisories (4)
Hersteller- und Ökosystem-Meldungen dazu.
- SSA-943925SSA-943925: Multiple Vulnerabilities in SINEC NMS before V2.0 SP12024-02-13csaf · siemens_psirtDE
SINEC NMS before V2.0 SP1 is affected by multiple vulnerabilities. Siemens has released an update for SINEC NMS and recommends to update to the latest version.
- WID-SEC-W-2023-2038PostgreSQL: Mehrere SchwachstellenDeutsch2023-08-10csaf · cert_bundDE
Ein entfernter authentifizierter Angreifer kann mehrere Schwachstellen in PostgreSQL ausnutzen, um beliebigen Code auszuführen oder Sicherheitsmaßnahmen zu umgehen.
- ICSA-24-046-15Siemens SINEC NMS2024-02-13icsa · cisa_csaf_otUS
SINEC NMS before V2.0 SP1 is affected by multiple vulnerabilities. Siemens has released an update for SINEC NMS and recommends to update to the latest version.
- BIT-postgresql-2023-39418Postgresql: merge fails to enforce update or select row security policies2024-03-06vendor · osvUS
A vulnerability was found in PostgreSQL with the use of the MERGE command, which fails to test new rows against row security policies defined for UPDATE and SELECT. If UPDATE and SELECT policies forbid some rows that INSERT policies do not forbid, a user could store such rows.
auch bekannt als (4)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (28)
Externe Belege — Patches, Meldungen, Analysen.
- https://access.redhat.com/security/cve/CVE-2023-39418cnnvd
- https://access.redhat.com/security/cve/cve-2023-39418cnnvd
- https://bugzilla.redhat.com/show_bug.cgi?id=2228112cnnvd
- https://cxsecurity.com/cveshow/CVE-2023-39418/cnnvd
- https://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=cb2ae5741f2458a474ed3c31458d242e678ff229cnnvd
- https://security.netapp.com/advisory/ntap-20230915-0002/cnnvd
- https://www.auscert.org.au/bulletins/ESB-2023.4767cnnvd
- https://www.auscert.org.au/bulletins/ESB-2023.6629cnnvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan