CVE-2022-44566
highPriorität · verfolgen · 30EPSS 0.013 · 70. PerzentilDEEURUUSEPSS · bewertet 2026-10-27
A denial of service vulnerability present in ActiveRecord's PostgreSQL adapter <7.0.4.1 and <6.1.7.1. When a value outside the range for a 64bit signed integer is provided to the PostgreSQL connection adapter, it will treat the target column type as numeric. Comparing integer values against numeric values can result in a slow sequential scan resulting in potential Denial of Service.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · medium–high · 6.9–7.5
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (22)
Betroffene Produkte und Versionsbereiche.
- activerecord project activerecord< 6.1.7.1nvdUScpe:2.3:a:activerecord_project:activerecord:*:*:*:*:*:*:*:*
- activerecord project activerecord7.0.0 → 7.0.4.1nvdUScpe:2.3:a:activerecord_project:activerecord:*:*:*:*:*:*:*:*
Advisories (3)
Hersteller- und Ökosystem-Meldungen dazu.
- WID-SEC-W-2023-0114Ruby on Rails: Mehrere SchwachstellenDeutsch2023-01-17csaf · cert_bundDE
Ein entfernter Angreifer kann mehrere Schwachstellen in Ruby on Rails ausnutzen, um einen Denial of Service Angriff durchzuführen, Daten zu manipulieren und Sicherheitsmaßnahmen zu umgehen.
- WID-SEC-W-2023-2101genua genucenter: Mehrere SchwachstellenDeutsch2023-08-20csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in genua genucenter ausnutzen, um Informationen offenzulegen, Dateien zu manipulieren, um Cross-Site Scripting Angriffe durchzuführen oder um einen nicht näher spezifizierten Angriff durchzuführen.
- GHSA-579w-22j4-4749Denial of Service Vulnerability in ActiveRecord's PostgreSQL adapter2023-01-18ghsa · osvUS
There is a potential denial of service vulnerability present in ActiveRecord's PostgreSQL adapter. This has been assigned the CVE identifier CVE-2022-44566. Versions Affected: All. Not affected: None. ## Fixed Versions - 2.3.18.47 (Rails LTS, which is a paid service and not part of the rubygem) - 3.2.22.34 (Rails LTS, which is a paid service and not part of the rubygem) - 4.2.11.27 (Rails LTS, which is a paid service and not part of the rubygem) - 5.2.8.15 (Rails LTS, which is a paid service and not part of the rubygem) - 6.1.7.1 - 7.0.4.1 ## Impact In ActiveRecord < 7.0.4.1 and < 6.1.7.1, when a value outside the range for a 64bit signed integer is provided to the PostgreSQL connection adapter, it will treat the target column type as numeric. Comparing integer values against numeric values can result in a slow sequential scan resulting in potential Denial of Service. ## Releases The fixed releases are available at the normal locations. ## Workarounds Ensure that user supplied input which is provided to ActiveRecord clauses do not contain integers wider than a signed 64bit representation or floats. ## Patches To aid users who aren't able to upgrade immediately we have provided patches for the supported release series in accordance with our maintenance policy 1 regarding security issues. They are in git-am format and consist of a single changeset. 6-1-Added-integer-width-check-to-PostgreSQL-Quoting.patch - Patch for 6.1 series 7-0-Added-integer-width-check-to-PostgreSQL-Quoting.patch - Patch for 7.0 series
auch bekannt als (4)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (11)
Externe Belege — Patches, Meldungen, Analysen.
- https://access.redhat.com/security/cve/cve-2022-44566cnnvd
- https://code.jeremyevans.net/2022-11-01-forcing-sequential-scans-on-postgresql.htmlcnnvd
- https://cxsecurity.com/cveshow/CVE-2022-44566/cnnvd
- https://discuss.rubyonrails.org/t/cve-2022-44566-possible-denial-of-service-vulnerability-in-activerecords-postgresql-adapter/82119cnnvd
- https://rubygems.org/gems/activerecord/versions/7.0.4.2Patchcnnvd
- https://www.auscert.org.au/bulletins/ESB-2023.1218cnnvd
- https://www.auscert.org.au/bulletins/ESB-2023.1339cnnvd
- https://code.jeremyevans.net/2022-11-01-forcing-sequential-scans-on-postgresql.htmlenisa_euvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan