CVE-2022-31175
mediumPriorität · verfolgen · 19EPSS 0.009 · 59. PerzentilEUUSEPSS · bewertet 2026-10-27
CKEditor 5 is a JavaScript rich text editor. A cross-site scripting vulnerability has been discovered affecting three optional CKEditor 5's packages in versions prior to 35.0.1. The vulnerability allowed to trigger a JavaScript code after fulfilling special conditions. The affected packages are `@ckeditor/ckeditor5-markdown-gfm`, `@ckeditor/ckeditor5-html-support`, and `@ckeditor/ckeditor5-html-embed`. The specific conditions are 1) Using one of the affected packages. In case of `ckeditor5-html-support` and `ckeditor5-html-embed`, additionally, it was required to use a configuration that allows unsafe markup inside the editor. 2) Destroying the editor instance and 3) Initializing the editor on an element and using an element other than `<textarea>` as a base. The root cause of the issue was a mechanism responsible for updating the source element with the markup coming from the CKEditor 5 data pipeline after destroying the editor. This vulnerability might affect a small percent of integrators that depend on dynamic editor initialization/destroy and use Markdown, General HTML Support or HTML embed features. The problem has been recognized and patched. The fix is available in version 35.0.1. There are no known workarounds for this issue.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (7)
Betroffene Produkte und Versionsbereiche.
- ckeditor ckeditor5-html-support< 35.0.1nvdUScpe:2.3:a:ckeditor:ckeditor5-html-support:*:*:*:*:*:*:*:*
- ckeditor ckeditor5-markdown-gfm< 35.0.1nvdUScpe:2.3:a:ckeditor:ckeditor5-markdown-gfm:*:*:*:*:*:*:*:*
Advisories (1)
Hersteller- und Ökosystem-Meldungen dazu.
- GHSA-42wq-rch8-6f6jCKEditor5 cross-site scripting vulnerability caused by the editor instance destroying process2022-08-06ghsa · osvUS
### Affected packages @ckeditor/ckeditor5-markdown-gfm @ckeditor/ckeditor5-html-support @ckeditor/ckeditor5-html-embed ### Impact A cross-site scripting vulnerability has been discovered affecting three optional CKEditor 5's packages. The vulnerability allowed to trigger a JavaScript code after fulfilling special conditions: a) Using one of the affected packages. In case of `ckeditor5-html-support` and `ckeditor5-html-embed`, additionally, it was required to use a configuration that allows unsafe markup inside the editor, b) Initializing the editor on an element and using an element other than `<textarea>` as a base, c) Destroying the editor instance. The root cause of the issue was a mechanism responsible for updating the source element with the markup coming from the CKEditor 5 data pipeline after destroying the editor. This vulnerability might affect a small percent of integrators that depend on dynamic editor initialization/destroy and use [Markdown](https://ckeditor.com/docs/ckeditor5/latest/features/markdown.html), [General HTML Support](https://ckeditor.com/docs/ckeditor5/latest/features/general-html-support.html) or [HTML embed](https://ckeditor.com/docs/ckeditor5/latest/features/html-embed.html) features. ### Patches The problem has been recognized and patched. The fix will be available in version 35.0.1. ### For more information Email us at [security@cksource.com](mailto:security@cksource.com) if you have any questions or comments about this advisory.
auch bekannt als (3)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (14)
Externe Belege — Patches, Meldungen, Analysen.
- https://ckeditor.com/docs/ckeditor5/latest/features/general-html-support.htmlcnnvd
- https://ckeditor.com/docs/ckeditor5/latest/features/html-embed.htmlcnnvd
- https://ckeditor.com/docs/ckeditor5/latest/features/markdown.htmlcnnvd
- https://cxsecurity.com/cveshow/CVE-2022-31175/cnnvd
- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-42wq-rch8-6f6jcnnvd
- https://vigilance.fr/vulnerability/CKEditor-Cross-Site-Scripting-via-Instance-Destroying-Process-38984cnnvd
- https://ckeditor.com/docs/ckeditor5/latest/features/general-html-support.htmlenisa_euvd
- https://ckeditor.com/docs/ckeditor5/latest/features/html-embed.htmlenisa_euvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan