CVE-2022-31093
mediumPriorität · verfolgen · 31EPSS 0.017 · 78. PerzentilEUUSEPSS · bewertet 2026-10-28
NextAuth.js is a complete open source authentication solution for Next.js applications. In affected versions an attacker can send a request to an app using NextAuth.js with an invalid `callbackUrl` query parameter, which internally is converted to a `URL` object. The URL instantiation would fail due to a malformed URL being passed into the constructor, causing it to throw an unhandled error which led to the **API route handler timing out and logging in to fail**. This has been remedied in versions 3.29.5 and 4.5.0. If for some reason you cannot upgrade, the workaround requires you to rely on Advanced Initialization. Please see the documentation for more.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · medium–high · 5–7.5
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (6)
Betroffene Produkte und Versionsbereiche.
Advisories (1)
Hersteller- und Ökosystem-Meldungen dazu.
- GHSA-g5fm-jp9v-2432Improper Handling of `callbackUrl` parameter in next-auth2022-06-21ghsa · osvUS
### Impact An attacker can send a request to an app using NextAuth.js with an invalid `callbackUrl` query parameter, which internally we convert to a `URL` object. The URL instantiation would fail due to a malformed URL being passed into the constructor, causing it to throw an unhandled error which led to our **API route handler timing out and logging in to fail**. This has been remedied in the following releases: next-auth v3 users before version 3.29.5 are impacted. (We recommend upgrading to v4, as v3 is considered unmaintained. See our [migration guide](https://next-auth.js.org/getting-started/upgrade-v4)) next-auth v4 users before version 4.5.0 are impacted. ### Patches We've released patches for this vulnerability in: - v3 - `3.29.5` - v4 - `4.5.0` You can do: ```sh npm i next-auth@latest ``` or ```sh yarn add next-auth@latest ``` or ```sh pnpm add next-auth@latest ``` (This will update to the latest v4 version, but you can change `latest` to `3` if you want to stay on v3. This is not recommended.) ### Workarounds If for some reason you cannot upgrade, the workaround requires you to rely on [Advanced Initialization](https://next-auth.js.org/configuration/initialization#advanced-initialization). Here is an example: **Before:** ```js // pages/api/auth/[...nextauth].js import NextAuth from "next-auth" export default NextAuth(/* your config */) ``` **After:** ```js // pages/api/auth/[...nextauth].js import NextAuth from "next-auth" function isValidHttpUrl(url) { try { return /^https?:/.test(url).protocol } catch { return false; } } export default async function handler(req, res) { if ( req.query.callbackUrl && !isValidHttpUrl(req.query.callbackUrl) ) { return res.status(500).send(''); } return await NextAuth(req, res, /* your config */) } ``` ### References This vulnerability was discovered not long after https://github.com/nextauthjs/next-auth/security/advisories/GHSA-q2mx-j4x2-2h74 was published and is very similar in nature. Related documentation: - https://next-auth.js.org/getting-started/client#specifying-a-callbackurl - https://next-auth.js.org/configuration/callbacks#redirect-callback A test case has been added so this kind of issue will be checked before publishing. See: https://github.com/nextauthjs/next-auth/commit/e498483b23273d1bfc81be68339607f88d411bd6 ### For more information If you have any concerns, we request responsible disclosure, outlined here: https://next-auth.js.org/security#reporting-a-vulnerability ### Timeline The issue was reported 2022 June 10th, a response was sent out to the reporter in less than 2 hours, and a patch was published within 3 hours.
auch bekannt als (3)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (13)
Externe Belege — Patches, Meldungen, Analysen.
- https://cxsecurity.com/cveshow/CVE-2022-31093/cnnvd
- https://github.com/nextauthjs/next-auth/commit/25517b73153332d948114bacdff3b5908de91d85cnnvd
- https://github.com/nextauthjs/next-auth/commit/e498483b23273d1bfc81be68339607f88d411bd6cnnvd
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-g5fm-jp9v-2432cnnvd
- https://next-auth.js.org/configuration/initialization#advanced-initializationcnnvd
- https://github.com/nextauthjs/next-auth/commit/25517b73153332d948114bacdff3b5908de91d85enisa_euvd
- https://github.com/nextauthjs/next-auth/commit/e498483b23273d1bfc81be68339607f88d411bd6enisa_euvd
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-g5fm-jp9v-2432enisa_euvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan