CVE-2022-24775
mediumPriorität · verfolgen · 31EPSS 0.025 · 84. PerzentilEURUUSEPSS · bewertet 2026-10-27
guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · medium–high · 5–7.5
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (18)
Betroffene Produkte und Versionsbereiche.
Advisories (3)
Hersteller- und Ökosystem-Meldungen dazu.
- GHSA-q7rv-6hp3-vh96Improper Input Validation in guzzlehttp/psr72022-03-25ghsa · osvUS
### Impact Improper header parsing. An attacker could sneak in a carriage return character (`\r`) and pass untrusted values in both the header names and values. ### Patches The issue is patched in 1.8.4 and 2.1.1. ### Workarounds There are no known workarounds. ### References * https://www.rfc-editor.org/rfc/rfc7230#section-3.2.4
- BIT-drupal-2022-24775Improper Input Validation in guzzlehttp/psr72024-03-06vendor · osvUS
guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.
- DRUPAL-CORE-2022-0062022-03-21vendor · osvUS
Drupal uses the third-party Guzzle library for handling HTTP requests and responses to external services. [Guzzle has released a security update](https://github.com/guzzle/psr7/security/advisories/GHSA-q7rv-6hp3-vh96) which may affect some Drupal sites. We are issuing this security advisory outside our regular [Drupal security release window schedule](https://www.drupal.org/node/1173280) since Guzzle has already published information about the vulnerability, and vulnerabilities might exist with core, contributed modules, or custom modules that use Guzzle for outgoing requests. Guzzle has rated this vulnerability as low-risk. This advisory is not covered by Drupal Steward.
auch bekannt als (7)
Weitere Namen und Kennungen dieser Entität.
- CNNVD-202203-1903cnnvd
- EUVD-2022-1513enisa_euvd
- BDU:2024-01894fstec_bdu
- GHSA-q7rv-6hp3-vh96enisa_euvd
- BIT-drupal-2022-24775osv
- DRUPAL-CORE-2022-006osv
- GHSA-q7rv-6hp3-vh96osv
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (17)
Externe Belege — Patches, Meldungen, Analysen.
- https://cxsecurity.com/cveshow/CVE-2022-24775/cnnvd
- https://github.com/guzzle/psr7/pull/485/commits/e55afaa3fc138c89adf3b55a8ba20dc60d17f1f1cnnvd
- https://github.com/guzzle/psr7/pull/486/commits/9a96d9db668b485361ed9de7b5bf1e54895df1dccnnvd
- https://github.com/guzzle/psr7/security/advisories/GHSA-q7rv-6hp3-vh96cnnvd
- https://vigilance.fr/vulnerability/Guzzle-header-injection-via-PSR-7-37854cnnvd
- https://www.auscert.org.au/bulletins/ESB-2022.1192cnnvd
- https://www.auscert.org.au/bulletins/ESB-2024.0014cnnvd
- https://www.cybersecurity-help.cz/vdb/SB2022032133cnnvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan