CVE-2021-41103
highPriorität · verfolgen · 31OT-Risiko · erhöhtEPSS 0.005 · 43. PerzentilDEEURUUSEPSS · bewertet 2026-10-24
containerd is an open source container runtime with an emphasis on simplicity, robustness and portability. A bug was found in containerd where container root directories and some plugins had insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as setuid), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. This vulnerability has been fixed in containerd 1.4.11 and containerd 1.5.7. Users should update to these version when they are released and may restart containers or update directory permissions to mitigate the vulnerability. Users unable to update should limit access to the host to trusted users. Update directory permission on container bundles directories.
Behebungen
Hersteller-Fix, Mitigation oder Workaround, wie von den Quellen veröffentlicht.
Ein Hersteller-Fix ist verfügbar.
- BehobenSCALANCE LPE9403siemens_psirt
Update to V2.0 or later version
https://support.industry.siemens.com/cs/ww/en/view/109811123/ - BehobenSCALANCE LPE9403cisa_csaf_ot
Update to V2.0 or later version
https://support.industry.siemens.com/cs/ww/en/view/109811123/
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · medium–high · 5.9–7.8
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (22)
Betroffene Produkte und Versionsbereiche.
Advisories (4)
Hersteller- und Ökosystem-Meldungen dazu.
- SSA-222547SSA-222547: Third-Party Component Vulnerabilities in SCALANCE LPE9403 before V2.02022-06-14csaf · siemens_psirtDE
Multiple vulnerabilities in the third-party components CivetWeb, Docker, Linux Kernel and systemd could allow an attacker to impact SCALANCE LPE9403 confidentiality, integrity and availability. Siemens has released an update for the SCALANCE LPE9403 and recommends to update to the latest version.
- GHSA-c2h3-6mxw-7mvqInsufficiently restricted permissions on plugin directories2021-10-04ghsa · osvUS
### Impact A bug was found in containerd where container root directories and some plugins had insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as setuid), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. ### Patches This vulnerability has been fixed in containerd 1.4.11 and containerd 1.5.7. Users should update to these version when they are released and may restart containers or update directory permissions to mitigate the vulnerability. ### Workarounds Limit access to the host to trusted users. Update directory permission on container bundles directories. ### For more information If you have any questions or comments about this advisory: * Open an issue in [github.com/containerd/containerd](https://github.com/containerd/containerd/issues/new/choose) * Email us at [security@containerd.io](mailto:security@containerd.io)
- ICSA-22-167-09Siemens SCALANCE LPE9403 Third-Party Vulnerabilities2022-06-14icsa · cisa_csaf_otUS
Multiple vulnerabilities in the third-party components CivetWeb, Docker, Linux Kernel and systemd could allow an attacker to impact SCALANCE LPE9403 confidentiality, integrity and availability. Siemens has released an update for the SCALANCE LPE9403 and recommends to update to the latest version.
- GO-2022-0938Insufficiently restricted permissions on plugin directories in github.com/containerd/containerd2024-08-21vendor · osvUS
Insufficiently restricted permissions on plugin directories in github.com/containerd/containerd
auch bekannt als (6)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (37)
Externe Belege — Patches, Meldungen, Analysen.
- https://access.redhat.com/security/cve/cve-2021-41103cnnvd
- https://cert-portal.siemens.com/productcert/pdf/ssa-222547.pdfcnnvd
- https://github.com/containerd/containerd/commit/5b46e404f6b9f661a205e28d59c982d3634148f8cnnvd
- https://github.com/containerd/containerd/security/advisories/GHSA-c2h3-6mxw-7mvqcnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/B5Q6G6I4W5COQE25QMC7FJY3I3PAYFBB/cnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZNFADTCHHYWVM6W4NJ6CB4FNFM2VMBIB/cnnvd
- https://packetstormsecurity.com/files/164388/Ubuntu-Security-Notice-USN-5100-1.htmlcnnvd
- https://packetstormsecurity.com/files/167778/Red-Hat-Security-Advisory-2022-5673-01.htmlcnnvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan