CVE-2021-34532

lowPriorität · verfolgen · 8EPSS 0.012 · 68. PerzentilEURUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
1.22% (68th) EPSS
CVSS 2.1 · low
Is it mine?
43 products
Prüfe deine Angriffsfläche
Who says so?
5 sources
cnnvd · enisa_euvd · fstec_bdu · osv

EPSS · bewertet 2026-10-27

ASP.NET Core and Visual Studio Information Disclosure Vulnerability

01

Behebungen

Hersteller-Fix, Mitigation oder Workaround, wie von den Quellen veröffentlicht.

Ein Hersteller-Fix ist verfügbar.

02

cvss

Technischer Schweregrad, 0–10. Eine Zeile je Quelle.

5.5
010

Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · low–medium · 1.8–5.5

v2.02.1lowAV:L/AC:L/Au:N/C:P/I:N/A:Nprimary · NVD / NIST USAusnutzbarkeit 3.9 · Auswirkung 2.9
v2.01.8lowAV:L/AC:L/Au:N/C:P/I:N/A:N/E:Usecondary · CVSS-BT (t0sche)
v3.15.5mediumAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:Nsecondary · FSTEC (BDU) RU
v3.15.5mediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:Csecondary · ENISA EU
v3.15.5mediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:Nsecondary · secure@microsoft.com USAusnutzbarkeit 1.8 · Auswirkung 3.6
v3.15.5mediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:Nsecondary · OSV
v3.15.5mediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:Csecondary · Microsoft Security Response Center US
v3.15.5mediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:Nsecondary · NVD / NIST USAusnutzbarkeit 1.8 · Auswirkung 3.6
03

schwächen

Die CWE-Schwächeklassen, zu denen dies gehört.

04

betroffene Produkte (43)

Betroffene Produkte und Versionsbereiche.

05

Advisories (3)

Hersteller- und Ökosystem-Meldungen dazu.

  • msrc_CVE-2021-34532ASP.NET Core and Visual Studio Information Disclosure Vulnerability2021-08-10csaf · msrc_csafUS

    To determine the support lifecycle for your software, see the Microsoft Support Lifecycle: https://support.microsoft.com/lifecycle

  • GHSA-q7cg-43mg-qp69ASP.NET Core Information Disclosure Vulnerability2021-08-25ghsa · osvUS

    Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 5.0, .NET Core 3.1 and .NET Core 2.1. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. An information disclosure vulnerability exists in .NET 5.0, .NET Core 3.1 and .NET Core 2.1 where a JWT token is logged if it cannot be parsed. ### Patches * If you're using .NET 5.0, you should download and install Runtime 5.0.9 or SDK 5.0.206 (for Visual Studio 2019 v16.8) or SDK 5.0.303 (for Visual Studio 2019 V16.10) from https://dotnet.microsoft.com/download/dotnet-core/5.0. * If you're using .NET Core 3.1, you should download and install Runtime 3.1.18 or SDK 3.1.118 (for Visual Studio 2019 v16.4) or 3.1.412 (for Visual Studio 2019 v16.7 or later) from https://dotnet.microsoft.com/download/dotnet-core/3.1. * If you're using .NET Core 2.1, you should download and install Runtime 2.1.29 or SDK 2.1.525 (for Visual Studio 2019 v15.9) or 2.1.817 from https://dotnet.microsoft.com/download/dotnet-core/2.1. * If your application is using .NET Core 2.1 running on .NET Framework see the [Updating .NET Core 2.1 on .NET Framework](#updating-2.1) section below. ### <a name="updating-2.1"></a> Updating .NET Core 2.1 on .NET Framework If you are running .NET Core 2.1 on .NET Framework you need to check your projects for dependencies and update them accordingly. #### Direct dependencies Direct dependencies are discoverable by examining your `csproj` file. They can be fixed by [editing the project file](#fixing-direct-dependencies) or using NuGet to update the dependency. #### Transitive dependencies Transitive dependencies occur when you add a package to your project that in turn relies on another package. For example, if Contoso publishes a package `Contoso.Utility` which, in turn, depends on `Contoso.Internals` and you add the `Contoso.Utility` package to your project now your project has a direct dependency on `Contoso.Utility` and, because `Contoso.Utility` depends 'Contoso.Internals', your application gains a transitive dependency on the `Contoso.Internals` package. Transitive dependencies are reviewable in two ways: * In the Visual Studio Solution Explorer window, which supports searching. * By examining the `project.assets.json` file contained in the obj directory of your project for `csproj` based projects The `project.assets.json` files are the authoritative list of all packages used by your project, containing both direct and transitive dependencies. There are two ways to view transitive dependencies. You can either [use Visual Studio’s Solution Explorer](#vs-solution-explorer), or you can review [the `project.assets.json` file](#project-assets-json)). ##### <a name="vs-solution-explorer"></a>Using Visual Studio Solution Explorer To use Solution Explorer, open the project in Visual Studio, and then press Ctrl+; to activate the search in Solution Explorer. Search for the [vulnerable package](#affected-software) and make a note of the version numbers of any results you find. For example, search for `Microsoft.AspNetCore.Authentication.JwtBearer` and update the package to the latest version ##### <a name="project-assets-json"></a> Manually reviewing project.assets.json Open the *project.assets.json* file from your project’s obj directory in your editor. We suggest you use an editor that understands JSON and allows you to collapse and expand nodes to review this file. Visual Studio and Visual Studio Code provide JSON friendly editing. Search the *project.assets.json* file for the [vulnerable package](#affected-software), using the format `packagename/` for each of the package names from the preceding table. If you find the assembly name in your search: * Examine the line on which they are found, the version number is after the `/`. * Compare to the [vulnerable versions table](#affected-software). For example, a search result that shows `Microsoft.AspNetCore.Authentication.JwtBearer/2.1.0` is a reference to version 2.1.1 of `Microsoft.AspNetCore.Authentication.JwtBearer`. If your *project.assets.json* file includes references to the [vulnerable package](#affected-software), then you need to fix the transitive dependencies. If you have not found any reference to any vulnerable packages, this means either * None of your direct dependencies depend on any vulnerable packages, or * You have already fixed the problem by updating the direct dependencies. #### Other Details - Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/195 - An Issue for this can be found at https://github.com/dotnet/aspnetcore/issues/35246 - MSRC details for this can be found at https://msrc.microsoft.com/update-guide/en-US/vulnerability/CVE-2021-34532

  • BIT-aspnet-core-2021-34532ASP.NET Core and Visual Studio Information Disclosure Vulnerability2024-03-06vendor · osvUS

    ASP.NET Core and Visual Studio Information Disclosure Vulnerability

06

auch bekannt als (6)

Weitere Namen und Kennungen dieser Entität.

07

quellen

Welche Quellen diesen Datensatz belegen und wann.

veröffentlicht 2021-08-12geändert 2026-08-10
08

Referenzen (13)

Externe Belege — Patches, Meldungen, Analysen.

scry

Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.

Kostenloser Scan