CVE-2021-22883
highPriorität · beachten · 57EPSS 0.774 · 100. PerzentilDEEURUUSEPSS · bewertet 2026-10-24
Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.
Behebungen
Hersteller-Fix, Mitigation oder Workaround, wie von den Quellen veröffentlicht.
Ein Hersteller-Fix ist verfügbar.
- Behobenfesto_psirt
FactoryViews (non-Lite): Upgrade to FactoryViews 1.6.0. See the upgrade guide for information on how to upgrade. FactoryViews Lite: Upgrade to FactoryViews 1.7.0. See the upgrade guide for information on how to upgrade.
- BehobenSINEC INSsiemens_psirt
Update to V1.0.1.1 or later version
https://support.industry.siemens.com/cs/ww/en/view/109806100/ - BehobenSINEC INScisa_csaf_ot
Update to V1.0.1.1 or later version
https://support.industry.siemens.com/cs/ww/en/view/109806100/ - Mitigatione-mesh EMScisa_csaf_ot
Do not directly connect to the Internet.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (68)
Betroffene Produkte und Versionsbereiche.
Advisories (7)
Hersteller- und Ökosystem-Meldungen dazu.
- FSA-202302Festo: Several vulnerabilities in FactoryViews2023-07-10csaf · festo_psirtDE
FactoryViews bundles many third-party applications which are used in background processes to provide the software's features. From time to time, vulnerabilities in these bundled applications are discovered. These are typically fixed in newer versions of FactoryViews by updating the bundled applications. FactoryViews versions up to and including 1.5.2 contain around 200 such vulnerabilities listed in this advisory.Version 1.6.0 is a security rollup release which includes updates to all bundled applications and fixes these vulnerabilities. At this time, FactoryViews Lite cannot be updated beyond version 1.1. FactoryViews 1.7 unifies the non-Lite and Lite versions and fixes these vulnerabilities for users of FactoryViews Lite.
- SSA-389290SSA-389290: Third-Party Component Vulnerabilities in SINEC INS2022-03-08csaf · siemens_psirtDE
71 vulnerabilities in third-party components as Node.js, cURL, SQLite, CivetWeb and DNS(ISC BIND) could allow an attacker to interfere with the affected product in various ways. Siemens has released an update for SINEC INS and recommends to update to the latest versions.
- WID-SEC-W-2023-0485Node.js: Mehrere Schwachstellen ermöglichen Denial of ServiceDeutsch2021-02-23csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Node.js ausnutzen, um einen Denial of Service Angriff durchzuführen.
- ICSA-22-069-09Siemens SINEC INS2022-03-08icsa · cisa_csaf_otUS
71 vulnerabilities in third-party components as Node.js, cURL, SQLite, CivetWeb and DNS(ISC BIND) could allow an attacker to interfere with the affected product in various ways. Siemens has released an update for SINEC INS and recommends to update to the latest versions.
- ICSA-22-090-02Hitachi Energy e-mesh EMS2022-03-31icsa · cisa_csaf_otUS
Successful exploitation of these vulnerabilities could cause a denial-of-service condition.
- BIT-node-2021-228832024-03-06vendor · osvUS
Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.
- BIT-node-min-2021-228832024-12-16vendor · osvUS
Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.
auch bekannt als (6)
Weitere Namen und Kennungen dieser Entität.
- CNNVD-202102-1509cnnvd
- EUVD-2021-10016enisa_euvd
- BDU:2021-01896fstec_bdu
- GHSA-mjgw-69fr-p4h2enisa_euvd
- BIT-node-2021-22883osv
- BIT-node-min-2021-22883osv
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (61)
Externe Belege — Patches, Meldungen, Analysen.
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdfcnnvd
- https://hackerone.com/reports/1043360cnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/E4FRS5ZVK4ZQ7XIJQNGIKUXG2DJFHLO7/cnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/F45Y7TXSU33MTKB6AGL2Q5V5ZOCNPKOG/cnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HSYFUGKFUSZ27M5TEZ3FKILWTWFJTFAZ/cnnvd
- https://nodejs.org/en/blog/vulnerability/february-2021-security-releases/cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2021-22883cnnvd
- https://packetstormsecurity.com/files/161665/Red-Hat-Security-Advisory-2021-0734-01.htmlcnnvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan