CVE-2019-20921
mediumPriorität · verfolgen · 25EPSS 0.017 · 78. PerzentilDEEUUSEPSS · bewertet 2026-10-27
bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.
Behebungen
Hersteller-Fix, Mitigation oder Workaround, wie von den Quellen veröffentlicht.
Ein Hersteller-Fix ist verfügbar.
- Behobenovirt-web-ui-0:1.6.7-1.el8ev.noarch as a component of RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/2974891
https://access.redhat.com/errata/RHSA-2021:1169 - Behobenovirt-web-ui-0:1.6.7-1.el8ev.src as a component of RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/2974891
https://access.redhat.com/errata/RHSA-2021:1169 - Behobenovirt-engine-ui-extensions-0:1.2.5-1.el8ev.noarch as a component of RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/2974891
https://access.redhat.com/errata/RHSA-2021:1186 - Behobenovirt-engine-ui-extensions-0:1.2.5-1.el8ev.src as a component of RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/2974891
https://access.redhat.com/errata/RHSA-2021:1186
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (45)
Betroffene Produkte und Versionsbereiche.
- IBM Tivoli Network Manager IP Edition 4.2alle Versionencert_bundDEcpe:/a:ibm:tivoli_network_manager:ip_edition_4.2
- snapappointments bootstrap-select< 1.13.6nvdUScpe:2.3:a:snapappointments:bootstrap-select:*:*:*:*:*:*:*:*
Advisories (5)
Hersteller- und Ökosystem-Meldungen dazu.
- RHSA-2021:1169Red Hat Security Advisory: RHV Manager (ovirt-engine) 4.4.z [ovirt-4.4.5] security, bug fix, enhancement2021-04-14csaf · redhat_csafUS
An update is now available for Red Hat Virtualization Engine 4.4. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.
- RHSA-2021:1186Red Hat Security Advisory: RHV Manager (ovirt-engine) 4.4.z [ovirt-4.4.5] 0-day security, bug fix, enhance2021-04-14csaf · redhat_csafUS
An update for org.ovirt.engine-root, ovirt-engine-ui-extensions, and ovirt-web-ui is now available for Red Hat Virtualization Engine 4.4. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.
- WID-SEC-W-2022-0808Red Hat Virtualization Engine: Mehrere SchwachstellenDeutsch2021-04-14csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in der Red Hat Virtualization Engine ausnutzen, um einen Cross-Site Scripting Angriff durchzuführen, beliebigen Code auszuführen, einen Denial of Service Zustand auszulösen und kryptographische Maßnahmen zu umgehen.
- GHSA-7c82-mp33-r854Cross-site scripting in bootstrap-select2021-05-07ghsa · osvUS
bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.
- GHSA-9r7h-6639-v5mwCross-Site Scripting in bootstrap-select2020-09-03ghsa · osvUS
Versions of `bootstrap-select` prior to 1.13.6 are vulnerable to Cross-Site Scripting (XSS). The package does not escape `title` values on `<option>` tags. This may allow attackers to execute arbitrary JavaScript in a victim's browser. ## Recommendation Upgrade to version 1.13.6 or later.
auch bekannt als (6)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (18)
Externe Belege — Patches, Meldungen, Analysen.
- https://github.com/advisories/GHSA-9r7h-6639-v5mwcnnvd
- https://github.com/snapappointments/bootstrap-select/issues/2199cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2019-20921cnnvd
- https://packetstormsecurity.com/files/162171/Red-Hat-Security-Advisory-2021-1186-01.htmlcnnvd
- https://snyk.io/vuln/SNYK-JS-BOOTSTRAPSELECT-570457cnnvd
- https://vigilance.fr/vulnerability/Node-js-bootstrap-select-Cross-Site-Scripting-35331cnnvd
- https://www.auscert.org.au/bulletins/ESB-2021.1274cnnvd
- https://www.npmjs.com/advisories/1522cnnvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan