CVE-2019-11069
mediumPriorität · verfolgen · 31EPSS 0.018 · 79. PerzentilEUUSEPSS · bewertet 2026-10-27
Sequelize version 5 before 5.3.0 does not properly ensure that standard conforming strings are used.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · medium–high · 5–7.5
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (3)
Betroffene Produkte und Versionsbereiche.
Advisories (1)
Hersteller- und Ökosystem-Meldungen dazu.
- GHSA-2777-2vq8-c4v4SQL Injection in sequelize2019-04-11ghsa · osvUS
Versions of `sequelize` prior to 5.3.0 (excluding v3 and v4) are vulnerable to SQL Injection. PostgreSQL option`standard_conforming_strings` is not set to `on` by default, which may allow attackers to inject SQL statements due to poor handling of backslashes in string literals. ## Recommendation Upgrade to version 5.3.0 or later.
auch bekannt als (3)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (12)
Externe Belege — Patches, Meldungen, Analysen.
- https://github.com/sequelize/sequelize/blob/98cb17c17f73e2aa1792aa5a1d31216ba984b456/lib/dialects/postgres/connection-manager.js#L158-L160cnnvd
- https://github.com/sequelize/sequelize/pull/10746/filescnnvd
- https://github.com/sequelize/sequelize/releases/tag/v5.3.0cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2019-11069cnnvd
- https://github.com/sequelize/sequelize/blob/98cb17c17f73e2aa1792aa5a1d31216ba984b456/lib/dialects/postgres/connection-manager.js#L158-L160enisa_euvd
- https://github.com/sequelize/sequelize/commit/850c7fd04669e0fef9238b6dc4f8d6ee93ed71e9enisa_euvd
- https://github.com/sequelize/sequelize/pull/10746/filesenisa_euvd
- https://github.com/sequelize/sequelize/releases/tag/v5.3.0enisa_euvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan