CVE-2019-10157

lowPriorität · verfolgen · 22OT-Risiko · erhöhtEPSS 0.002 · 11. PerzentilDEEUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
0.21% (11th) EPSS
CVSS 2.1 · low
Is it mine?
8 products
Prüfe deine Angriffsfläche
Who says so?
5 sources
cnnvd · enisa_euvd · cert_bund · nvd

EPSS · bewertet 2026-10-27

It was found that Keycloak's Node.js adapter before version 4.8.3 did not properly verify the web token received from the server in its backchannel logout . An attacker with local access could use this to construct a malicious web token setting an NBF parameter that could prevent user access indefinitely.

01

cvss

Technischer Schweregrad, 0–10. Eine Zeile je Quelle.

5.5
010

Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · low–medium · 2.1–5.5

v2.02.1lowAV:L/AC:L/Au:N/C:N/I:N/A:Pprimary · NVD / NIST USAusnutzbarkeit 3.9 · Auswirkung 2.9
v3.05.5mediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:Hprimary · NVD / NIST USAusnutzbarkeit 1.8 · Auswirkung 3.6
v3.04.7mediumCVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:Hsecondary · ENISA EU
v3.04.7mediumCVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:Hsecondary · secalert@redhat.com USAusnutzbarkeit 1 · Auswirkung 3.6
v3.05.5mediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:Hsecondary · OSV
v3.05.1mediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H/E:Usecondary · CVSS-BT (t0sche)
02

schwächen

Die CWE-Schwächeklassen, zu denen dies gehört.

03

betroffene Produkte (8)

Betroffene Produkte und Versionsbereiche.

04

Advisories (2)

Hersteller- und Ökosystem-Meldungen dazu.

  • WID-SEC-W-2022-1947Red Hat Single Sign On: Mehrere SchwachstellenDeutsch2019-06-11csaf · cert_bundDE

    Ein Angreifer kann mehrere Schwachstellen in Red Hat Single Sign On ausnutzen, um einen Cross-Site Scripting Angriff durchzuführen, einen Denial of Service Zustand hervorzurufen, Informationen auszuspähen, Sicherheitsvorkehrungen zu umgehen oder beliebigen Programmcode auszuführen.

  • GHSA-68hw-vfh7-xvg8Forced Logout in keycloak-connect2019-06-13ghsa · osvUS

    Versions of `keycloak-connect` prior to 4.4.0 are vulnerable to Forced Logout. The package fails to validate JWT signatures on the `/k_logout` route, allowing attackers to logout users and craft malicious JWTs with NBF values that prevent user access indefinitely. ## Recommendation Upgrade to version 4.4.0 or later.

05

auch bekannt als (3)

Weitere Namen und Kennungen dieser Entität.

06

quellen

Welche Quellen diesen Datensatz belegen und wann.

veröffentlicht 2019-06-12geändert 2026-06-17
08

Referenzen (13)

Externe Belege — Patches, Meldungen, Analysen.

scry

Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.

Kostenloser Scan