CVE-2018-1000807
mediumPriorität · verfolgen · 33EPSS 0.041 · 91. PerzentilDEEUUSEPSS · bewertet 2026-10-27
Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · medium–high · 6.8–8.1
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (11)
Betroffene Produkte und Versionsbereiche.
- redhat enterprise linux workstation= 7.0nvdUScpe:2.3:o:redhat:enterprise_linux_workstation:*:*:*:*:*:*:*:*
Advisories (3)
Hersteller- und Ökosystem-Meldungen dazu.
- WID-SEC-W-2024-1099python-crypto: Mehrere SchwachstellenDeutsch2018-12-10csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in python-crypto ausnutzen, um beliebigen Programmcode auszuführen und um einen Denial of Service Zustand herbeizuführen.
- GHSA-p28m-34f6-967qPyOpenSSL Use-After-Free vulnerability2018-10-10ghsa · osvUS
It was discovered that pyOpenSSL incorrectly handled memory when handling X509 objects. A remote attacker could use this issue to cause pyOpenSSL to crash, resulting in a denial of service, or possibly execute arbitrary code. This attack appears to be exploitable via Depends on the calling application and if it retains a reference to the memory. This vulnerability appears to have been fixed in 17.5.0.
- PYSEC-2018-232018-10-08vendor · osvUS
Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.
auch bekannt als (6)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (14)
Externe Belege — Patches, Meldungen, Analysen.
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00014.htmlcnnvd
- https://access.redhat.com/errata/RHSA-2019:0085cnnvd
- https://github.com/pyca/pyopenssl/pull/723cnnvd
- https://usn.ubuntu.com/3813-1/cnnvd
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00014.htmlenisa_euvd
- https://access.redhat.com/errata/RHSA-2019:0085enisa_euvd
- https://github.com/pyca/pyopenssl/commit/e73818600065821d588af475b024f4eb518c3509enisa_euvd
- https://github.com/pyca/pyopenssl/pull/723enisa_euvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan