CVE-2017-15708
highPriorität · beachten · 55EPSS 0.179 · 97. PerzentilExploit · PoCDEEUUSEPSS · bewertet 2026-10-22
In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · high–critical · 7.5–9.8
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
Exploits (1)
Öffentlicher Proof-of-Concept- und Exploit-Code.
- HuSoul/CVE-2017-15708Apache synapse 反序列化 CVE–2017–15708PoC · poc_in_github
betroffene Produkte (22)
Betroffene Produkte und Versionsbereiche.
- IBM InfoSphere Information Server 11.7alle Versionencert_bundDEcpe:/a:ibm:infosphere_information_server:11.7
- IBM Tivoli Business Service Manageralle Versionencert_bundDEcpe:/a:ibm:tivoli_business_service_manager:-
- oracle financial services market risk measurement and management= 8.0.6nvdUScpe:2.3:a:oracle:financial_services_market_risk_measurement_and_management:*:*:*:*:*:*:*:*
- oracle financial services market risk measurement and management= 8.0.8nvdUScpe:2.3:a:oracle:financial_services_market_risk_measurement_and_management:*:*:*:*:*:*:*:*
- oracle peoplesoft enterprise peopletools= 8.56nvdUScpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:*:*:*:*:*:*:*:*
Advisories (2)
Hersteller- und Ökosystem-Meldungen dazu.
- WID-SEC-W-2022-1738IBM InfoSphere Information Server: Mehrere SchwachstellenDeutsch2022-10-16csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in IBM InfoSphere Information Server ausnutzen, um seine Privilegien zu erweitern, beliebigen Programmcode auszuführen, einen Cross-Site-Scripting-Angriff durchzuführen, Informationen offenzulegen, einen Denial of Service Zustand herbeizuführen, Dateien zu manipulieren oder Sicherheitsvorkehrungen zu umgehen.
- GHSA-p694-23q3-rvrcRemote Code Execution in Apache Synapse2020-11-04ghsa · osvUS
In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.
auch bekannt als (3)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (28)
Externe Belege — Patches, Meldungen, Analysen.
- http://www.ibm.com/support/docview.wss?uid=ibm10958165cnnvd
- https://lists.apache.org/thread.html/77f2accf240d25d91b47033e2f8ebec84ffbc6e6627112b2f98b66c9@%3Cdev.synapse.apache.org%3Ecnnvd
- https://lists.apache.org/thread.html/r0fb289cd38c915b9a13a3376134f96222dd9100f1ef66b41631865c6@%3Ccommits.doris.apache.org%3Ecnnvd
- https://packetstormsecurity.com/files/163529/Gentoo-Linux-Security-Advisory-202107-37.htmlcnnvd
- https://security.gentoo.org/glsa/202107-37cnnvd
- https://www.auscert.org.au/bulletins/ESB-2019.3165/cnnvd
- https://www.auscert.org.au/bulletins/ESB-2024.0095cnnvd
- https://www.cybersecurity-help.cz/vdb/SB2021071601cnnvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan