CVE-2014-7192
highPriorität · beachten · 55EPSS 0.130 · 96. PerzentilExploit · PoCEUUSEPSS · bewertet 2026-10-28
Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
Exploits (1)
Öffentlicher Proof-of-Concept- und Exploit-Code.
- EDB-34090Node Browserify 4.2.0 - Remote Code ExecutionPoC · exploit_db
betroffene Produkte (3)
Betroffene Produkte und Versionsbereiche.
Advisories (1)
Hersteller- und Ökosystem-Meldungen dazu.
- GHSA-5726-g6r9-5f22Potential for Script Injection in syntax-error2017-10-24ghsa · osvUS
Versions of `syntax-error` prior to 1.1.1 are affected by a cross-site scripting vulnerability which may allow a malicious file to execute code when browserified. ## Recommendation Update to version 1.1.1 or later.
auch bekannt als (3)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (14)
Externe Belege — Patches, Meldungen, Analysen.
- http://www-01.ibm.com/support/docview.wss?uid=swg21690815cnnvd
- http://www.securityfocus.com/bid/70105cnnvd
- http://xforce.iss.net/xforce/xfdb/96728cnnvd
- https://github.com/substack/node-syntax-error/commit/9aa4e66eb90ec595d2dba55e6f9c2dd9a668b309cnnvd
- https://nodesecurity.io/advisories/37Patchcnnvd
- https://nodesecurity.io/advisories/syntax-error-potential-script-injectioncnnvd
- http://www-01.ibm.com/support/docview.wss?uid=swg21690815enisa_euvd
- https://exchange.xforce.ibmcloud.com/vulnerabilities/96728enisa_euvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan