CVE-2012-6708

mediumPriorität · verfolgen · 37EPSS 0.086 · 95. PerzentilExploit · PoCDEEURUUS
grimoire priorityP1 · Urgent
Exploitable?
Public exploit
1 exploit · PoC
Likely / severe?
8.63% (95th) EPSS
CVSS 4.3 · medium
Is it mine?
43 products
Prüfe deine Angriffsfläche
Who says so?
9 sources
cnnvd · enisa_euvd · fstec_bdu · cert_bund

EPSS · bewertet 2026-10-22

jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery determined whether the input was HTML by looking for the '<' character anywhere in the string, giving attackers more flexibility when attempting to construct a malicious payload. In fixed versions, jQuery only deems the input to be HTML if it explicitly starts with the '<' character, limiting exploitability only to attackers who can control the beginning of a string, which is far less common.

01

Behebungen

Hersteller-Fix, Mitigation oder Workaround, wie von den Quellen veröffentlicht.

Ein Hersteller-Fix ist verfügbar.

  • Behobenwut_psirt

    Update the affected devices to the versions listed below.

  • Mitigationpepperl_fuchs_psirt

    An external protective measure is required. - Minimize network exposure for affected products and ensure that they are not accessible via the Internet. - Isolate affected products from the corporate network. - If remote access is required, use secure methods such as virtual private networks (VPNs).

  • Mitigationwut_psirt

    Access to the WBM should be limited to trustworthy networks or peers.

  • MitigationWHA-GW-F2D2-0-AS- Z2-ETHcisa_csaf_ot

    If remote access is required, use secure methods such as virtual private networks (VPNs).

  • MitigationWHA-GW-F2D2-0-AS- Z2-ETH.EIPcisa_csaf_ot

    If remote access is required, use secure methods such as virtual private networks (VPNs).

02

cvss

Technischer Schweregrad, 0–10. Eine Zeile je Quelle.

6.1
010

Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen

v2.04.3mediumAV:N/AC:M/Au:N/C:N/I:P/A:Nprimary · NVD / NIST USAusnutzbarkeit 8.6 · Auswirkung 2.9
v3.06.1mediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nprimary · NVD / NIST USAusnutzbarkeit 2.8 · Auswirkung 2.7
v3.06.1mediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · OSV
v3.06.1mediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · CISA US
v3.06.1mediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · Pepperl+Fuchs PSIRT DE
v3.05.8mediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:Psecondary · CVSS-BT (t0sche)
v3.16.1mediumAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · FSTEC (BDU) RU
v3.16.1mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · W&T PSIRT
03

schwächen

Die CWE-Schwächeklassen, zu denen dies gehört.

04

Exploits (1)

Öffentlicher Proof-of-Concept- und Exploit-Code.

05

betroffene Produkte (43)

Betroffene Produkte und Versionsbereiche.

06

Advisories (7)

Hersteller- und Ökosystem-Meldungen dazu.

  • VDE-2021-027Pepperl+Fuchs: WirelessHART-Gateway - Vulnerability may allow remote attackers to cause a Denial Of Service2021-10-16csaf · pepperl_fuchs_psirtDE

    Critical vulnerabilities have been discovered in the product and in the utilized components jQuery by jQuery Team and TLS Version 1.0/1.1. The impact of the vulnerabilities on the affected device may result in - denial of service - remote code execution - code exposure

  • VDE-2025-024Wiesemann & Theis: Multiple products from Wiesemann & Theis support deprecated jQuery version2025-05-13csaf · wut_psirtDE

    Multiple W&T devices are shipped with a jQuery version with a known XSS vulnerability.

  • WID-SEC-W-2026-1752IBM Business Automation Workflow: Mehrere SchwachstellenDeutsch2026-05-31csaf · cert_bundDE

    Ein Angreifer kann mehrere Schwachstellen in IBM Business Automation Workflow ausnutzen, um Sicherheitsvorkehrungen zu umgehen, um einen Denial of Service Angriff durchzuführen, um Informationen offenzulegen, um Dateien zu manipulieren, und um einen Cross-Site Scripting Angriff durchzuführen.

  • WID-SEC-W-2026-3720IBM Business Process Manager: Mehrere Schwachstellen ermöglichen Cross-Site ScriptingDeutsch2020-04-06csaf · cert_bundDE

    Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in IBM Business Process Manager ausnutzen, um einen Cross-Site Scripting Angriff durchzuführen.

  • WID-SEC-W-2026-3721IBM QRadar SIEM: Mehrere SchwachstellenDeutsch2021-05-04csaf · cert_bundDE

    Ein entfernter, anonymer, authentifizierter, lokaler oder benachbarter Angreifer kann mehrere Schwachstellen in IBM QRadar SIEM ausnutzen, um Informationen offenzulegen, Cross-Site-Scripting-Angriffe durchzuführen, Sicherheitsmaßnahmen zu umgehen, beliebigen Code auszuführen oder einen Denial of Service Zustand auszulösen.

  • GHSA-2pqj-h3vj-pqgwCross-Site Scripting in jquery2020-09-01ghsa · osvUS

    Affected versions of `jquery` are vulnerable to cross-site scripting. This occurs because the main `jquery` function uses a regular expression to differentiate between HTML and selectors, but does not properly anchor the regular expression. The result is that `jquery` may interpret HTML as selectors when given certain inputs, allowing for client side code execution. ## Proof of Concept ``` $("#log").html( $("element[attribute='<img src=\"x\" onerror=\"alert(1)\" />']").html() ); ``` ## Recommendation Update to version 1.9.0 or later.

  • ICSA-22-097-01Pepperl+Fuchs WirelessHART-Gateway2022-04-07icsa · cisa_csaf_otUS

    Successful exploitation of these vulnerabilities may result in a denial-of-service condition, code execution, and code exposure.

07

auch bekannt als (4)

Weitere Namen und Kennungen dieser Entität.

08

quellen

Welche Quellen diesen Datensatz belegen und wann.

10

Referenzen (59)

Externe Belege — Patches, Meldungen, Analysen.

scry

Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.

Kostenloser Scan