VDE-2026-009

csafDEjumo_psirt

JUMO: Multiple products affected by nodejs vulnerability

Advisory ansehen veröffentlicht 2026-05-26

A vulnerability in the REST API of the JUMO device allows an attacker to trigger a denial‑of‑service (DoS) condition. Due to an incorrect implementation of the arrayLimit option in the Node.js qs module, limits for incoming request parameters are not properly enforced. As a result, an attacker can send specially crafted requests containing excessively large or deeply nested arrays, causing the web server to become unresponsive. This condition leads to a crash of the web server, followed by an automatic restart of the device.

01

beschreibt (1)

Zugehörige CVEs.

IDSchweregrad ausnutzbar
CVE-2025-15284US——
Improper Input Validation vulnerability in qs (parse modules) allows HTTP DoS.This issue affects qs: < 6.14.1. Summary The arrayLimit option in qs did not enforce limits for bra…
02

Referenzen

Externe Belege — Patches, Meldungen, Analysen.

03

Behebungen (2)

  • Mitigation

    Limit access to the devices webserver (e.g. using a Firewall or apply rate limiting and DoS protection mechanisms at the API gateway).

  • Behoben

    Update the affected products to version 431.10.0.0.26 for variTRON 300, to version 388.10.0.0.26 for variTRON 500 and to version 446.10.0.0.26 for variTRON 500 touch. The release of this versions are expected to Q2 2026.

scry

Advisories wie diese benennen die exponierten Produkte, die Angreifer auf Ihrer Angriffsfläche ins Visier nehmen. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.

Kostenloser Scan