Apache Superset Deserialization of Untrusted Data vulnerability
If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend. The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges. This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.
beschreibt (1)
Zugehörige CVEs.
| ID | Schweregrad | ausnutzbar | ||
|---|---|---|---|---|
| CVE-2023-37941US | medium6.6 | Exploit | ||
If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Supers… | ||||
Referenzen
Externe Belege — Patches, Meldungen, Analysen.
- http://packetstormsecurity.com/files/175094/Apache-Superset-2.0.0-Remote-Code-Execution.htmlWEB
- https://github.com/advisories/GHSA-fj4x-m62j-wvwgADVISORY
- https://github.com/apache/supersetPACKAGE
- https://lists.apache.org/thread/6qk1zscc06yogxxfgz2bh2bvz6vh9g7hWEB
- https://nvd.nist.gov/vuln/detail/CVE-2023-37941ADVISORY
- https://pypi.org/project/apache-supersetPACKAGE
Advisories wie diese benennen die exponierten Produkte, die Angreifer auf Ihrer Angriffsfläche ins Visier nehmen. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan